Modules are not loading in Asterisk

I have seen multiple posts regarding this issue, but none of the workarounds worked for me. Hence opening this thread. I have installed Asterisk by following the below comands:

./configure
make menuconfig
make && make install

I tried different workarounds such as

  1. Changing the first command to ./configure -with-jansson-bundled -with-pjproject-bundled
  2. Enable module load in menu config
  3. Using commands such as make config / make samples after installing asterisk.

But whenever I try to start asterisk server, I get errors. Refer to this gist for full log:

Also, because of this error in loading modules, SIP commands are not working in asterisk CLI:

*CLI> sip show peers
No such command 'sip show peers' (type 'core show help sip show' for other possible commands)
*CLI> core sip show peers
No such command 'core sip show peers' (type 'core show help core sip show' for other possible commands)
*CLI> core show help sip
No such command 'sip'.
*CLI>

I’m using Asterisk 17.1.0

Please help me troubleshooting this issue. I’m sitting with this issue for days now.

Did you confirm you selected chan_sip in “make menuconfig”? (Did you accidentally unselect modules instead of selecting them)

Could you please explain which option needs to be selected in order to set chan_sip ?
I attached menuconfig screen that I’m seeing.

Update:
Nevermind, I selected it from "channel drivers -> chan_sip ".
However, the error is still there after the re-installation :frowning:

Does the chan_sip.so module exist in /usr/lib/asterisk/modules? What platform are you running on?

You will also need to run “make” and “make install” after ensuring it is selected.

I’m running the install on Ubuntu 18.04
And yeah, every time when I run the install, I run those commands (make && make install) after menuconfig.


I can see that chan_sip.so module exist in /usr/lib/asterisk/modules

And if you manually load the module using “module load chan_sip.so”?

This is what I see while I try to load the module manually:

It’s “module load chan_sip.so” not “modules load chan_sip.so”

reinstall a virtual machine and this time follow this tutorial: https://doc.ubuntu-fr.org/asterisk.
I installed asterisk several times by following this tutorial and have never had a problem.

Here is what I see now:

The module loaded, those are just warnings conveying that chan_sip is deprecated and to move to PJSIP if possible. This means that it is there and can be loaded. Have you checked your modules.conf to see if chan_sip is explicitly not being loaded?

This is likely all configuration related.

And what is your end goal with all of this? What are you hoping to achieve?

I want to setup local SIP server for a dev project. A SIP server to register multiple SIP clients and to make calls within LAN during development. I’m not sure about the required configurations. So, is there a step-by-step documentation on the same? Also, when I try to hit the command “sip show peers” after the installation, an error message comes “no command exist”.

There is the basic PBX configuration[1] which can be installed using “make basic-pbx”. You’re going to need to invest some time in learning things[2] to understand what is going on though. Asterisk is a toolkit that can be configured to do numerous things, it’s not an end-user product, so it’s up to you to learn, configure, and make it work as you precisely want.

As well, as I mentioned in my previous reply I’d suggest examining the modules.conf file in /etc/asterisk to see if modules are explicitly configured not to be loaded at startup.

[1] https://wiki.asterisk.org/wiki/display/AST/Super+Awesome+Company
[2] http://asteriskdocs.org/

Thank you for the response.
I’m looking for documentation especially on the configuration part. If you can point me to the right documentation page, then it would be helpful.

On the installation part, most of the errors were gone and I’m able to run SIP commands. I followed this documentation: https://doc.ubuntu-fr.org/asterisk as mentioned by @DadadoSenior

If you are making calls from the PBX, you need the PABX to be a SIP client.

However the key point here is that if you are doing a new installation of Asterisk as a SIP user agent, you should be using chan_pjsip, not chan_sip. chan _pjsip is just as much a SIP user agent as chan_sip.

There may be special cases in which chan_pjsip will not be suitable, but you should generally know what those are if they apply to you.

Asterisk, itself is a daemon, not a server.