Making outgoing call to a special number

Hi, I’m new to asterisk and to this forum and I’m writing because I have a problem when I try to call a special number (in Italy 199******).

My “mission” is the automatic call:

asterisk@raspbx:~ $ cat hello.call
Channel: SIP/out/199******
Context: myextension
Extension: 12345

and execute:

[ Context 'myextension' created by 'pbx_config' ]
  '12345' =>        1. Answer()                                   [extensions_custom.conf:2]
                    2. Wait(2)                                    [extensions_custom.conf:3]
                    3. SendDTMF(XXXXXXXXX,1,.5)                  [extensions_custom.conf:4]
                    4. Wait(10)                                   [extensions_custom.conf:5]
                    5. Playback(hello-world)                      [extensions_custom.conf:6]

When I try to start the automatic call the result is “SIP/out-00000013 is making progress” without ringing, and then “Call failed to go through, reason (3) Remote end Ringing”.

If I call my mobile number (instead of 199******), it works.
If I call the number 199****** with my provider configured on a VoIP app, it works.

Any suggestion? Thanks and sorry for my english!

Is this, by any chance, a free number? At least the old way of doing this was as early media. The cal was never answered, as it would have started metering of the call.

Hi @david551, thanks for the reply

Yes, this number is a free number! indeed when you call with the phone, the answer is immediate, it doesn’t ring

Carlo

You will need to call on a local channel, and Answer on that channel, then dead reckon, or do some sort of silence or AMD on the B leg, if that is the problem.

You may still have problems with the acceptability of upstream early media.

sometimes if you don’t set callerid at auto-call file, call is failed
how about setting callerid at auto-call file(hello.call)

I have accomplished similar task using the M option on the dial command, in order to use the dial command you will need a local channel, Note macro are deprecated but still works

Hi @nanaki82 You can also try this …

You can choose whether to display or hide your telephone number when making outgoing calls . To display your number on the following call , dial 1470. If you have a geographic number for the line, you can choose whether to display this or the 056 number .