Languageprefix does not seem to work

Greetings to all,

[This refers to Asterisk 1.4]

I’ve tried using the asterisk menuselect language install… the files are there, but the digits, etc. (all the subdirectories of /var/lib/asterisk/sounds/), are played in english. For all the files in /var/lib/asterisk/sounds/“language”/, whatever it may be (spanish or french), the digits are always played in english. HOWEVER the files directly in the /fr/ or whatever directory (i.e. not in a subdirectory) are played in the correct language.

Using what is suggested, i.e. you have to add languageprefix=yes in asterisk.conf, does absolutely nothing. The digits are still played in english no matter what. Seems like a bug to me.

I do not want to submit this as a bug on as the last person to complain about this was hung, drawn and quartered by the developers, so I’m hoping someone else will help me out here?

I may try the latest build see if this has been fixed, but since the untimely demise of the unlucky bug reporter who was unfortunate enough to even suggest that this may be a small “undocumented feature”, I’m thinking this has not been addressed.

Thanks for your help.

All right… does anyone have a correctly working multilingual asterisk 1.4 at this point, with the languages installed from scratch by asterisk itself?

Tried latest from SVN, doesn’t seem to build, which is weird since I can build 1.4 from FTP just fine.

It took me a minute, a small flaming on bugs, and a couple of tries, but languageprefix = yes does work. as per asterisk/doc/asterisk-conf.txt:

languageprefix = yes | no ; Should language code be last component of sound file name or first?
; when off, sound files are searched as //
; when on, sound files are search as //
; (only affects relative paths for sound files)

This setting belongs in the [options] sections of asterisk.conf like so:
languageprefix = yes