Is there any connections limit configuration in Asterisk 13 AsterNet ARI?

We are using AsterNet to implementing Auto Dial in our contact center for out calling.
It is a web service which get “from” and “to” and “projectCode” then it will use OriginateAsync method to make call as below:

    public void ClickToDialFromTo(string from, string to, int projectCode)
            AriClient ActionClient = new AriClient(new StasisEndpoint("voip", 8088, "root", "password"), "HelloWorld", false);


            ActionClient.Channels.OriginateAsync("SIP/" + from, + projectCode + to, "from-internal-additional", 1, null, null, null, to, null, null, null, null, null, null);


        catch (Exception ex)
            string err = ex.Message;

Everything is good when we test it directly but while we use the web service in Share Point forms (as a click to dial button), connection to asterisk (ActionClient.Connect()) goes to be interrupted right after agents start to call simultaneously.

Is there any configuration on Asterisk for connection request limit? May it be related to Allow-Access-Origin option on ARI.conf file?

Any one has any idea please?


The HTTP server has a session limit which by default is 100[1]. Besides that there are no other limits that come to mind. You’d need to actually look at the console output and see if anything pops up.


So much thanks @jcolp, it worked as well for about 50 agents simultaneously after changing sessionlimit to 1000 but after a while it stopped again and I changed the sessionlimit to 10000 !
It starts working again after reset ARI but how can I get active sessions count while it is working?

And why sessions remain even after connection interrupted by ActionClient.Disconnect and ActionClient.Dispose ?

I don’t think there is anything built in to show you sessions. I also don’t know AsterNet or how it works, so can’t comment on what happens after that. You could check “netstat -a” to see if sessions are still up.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.