Interesting problem after updating Asterisk 13 to Asterisk 16

Last week I updated my Asterisk 13 to Asterisk 16
I am using Freepbx

After that update I saw that MWI on my extension 995 was not working. (it did not show any notifications and there was no notify message to this sip client when I checked with tcpdump)

Then I read on forums that MWI was not working with old chan_sip and that pjsip should be used.
I converted my extension to pjsip and changed the port from 5160 to 5060
It worked. And MWI was working fine.

But today I noticed that the extension was not registered. (“pjsip show endpoints” command showed unavailable)

Then I checked the logs and in “full” log I saw that Asterisk was showing “address already in use” for 5060 port.
I checked all log files but did not see any use of 5060 other than in pjsip configuration.
Also Freepbx GUI only shows 5060 in pjsip config, and 5160 in chan_sip config.

But the situation is:


13:50:12.049554 IP > SIP: REGISTER sip: SIP/2.0
13:50:12.049806 IP > ICMP udp port sip unreachable, length 528


root@raspbx:/etc/asterisk# netstat -tulpn | grep 5060
udp 0 0* 15041/asterisk

After that, I changed the port on Freepbx GUI to 5062 for pjsip
I also changed the client config to register on Asterisk port 5062
It started working.


root@raspbx:/etc/asterisk# netstat -tulpn | grep 5060
root@raspbx:/etc/asterisk# netstat -tulpn | grep 5062
udp 0 0* 15240/asterisk

I can’t understand why it works with port 5062 and not with 5060

Any ideas ?
How can I troubleshoot this ?

Then I also checked my inbound trunks which were working on port 5160 previously (before update)

I saw that they were not working. (same situation, Asterisk binds to 5160 but does not work)
Then I changed chan_sip config from 5160 to 5162, and it started working.

Seems like my Asterisk is not working with default ports (although they bind) 5060 and 5160
but they work when bound to 5062 and 5162
is there a known reason for this ?

I also noticed that in my “sip_additional.conf” I have some weird extensions which I do not use.
I normally had chan_sip extensions 999 and 995 before updating to Asterisk 16.
After the update, I changed these 2 extensions to pjsip and they are fine in pjsip config files.
But I also see below extensions in files:

sip_additional.conf:callerid=Giris <99995>
sip_additional.conf:callerid=WebRTC <9999995>
sip_additional.conf:callerid=WebRTC <999999995>

what might be the reason for this and how can I remove them ? (should I ?)

Duplicated as Interesting problem after updating Asterisk 13 to Asterisk 16 - FreePBX Community Forums

yes because I am not sure if this is a Freepbx or Asterisk problem

The problem you can get if you post to both, without any cross-links, is that people waste time by providing answers that are already in the other forum, or miss additional information that is only there. Also, you make references to files that only exist in FreePBX.

I don’t believe that anyone would waste time answering both.
First, there might be “some” people who follow both forum AND who really has an answer.
If these people would decide to answer, they can copy and paste their answer to both questions. That really doesn’t mean they will waste 2x effort.
Besides, everyone can understand that this is the SAME question. And if one thinks it is a waste of time answering both , they can decide to answer only ONE of them.

On the other hand, as I suspected before, there is zero “real” answer on both forums.
So I believe posting my problem to both forums is still a good approach as these forums are separate.
They really belong to 2 different communities/organization and are not related.

My only mistake is that I have references to files that exist only on FreePBX. I agree with that.

if you use both chan_sip and chan_pjsip at the same time they have to use diffrent ports
so try disable chan_sip

You did not understand my issue.
I am (and was) already using different ports for chan_sip and pjsip (5160 and 5060)
but now these do not work.
I had to change them to 5162 and 5062 to make them work.

Why ?

I’d appreciate any ideas, help…

ohh the FreePBX have not solved it ???

do you still have a problem if you only use one sip channel driver
could it be a Firewall problem

iptables -L -n
firewall-cmd --list-all

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.