Asterisk 18 not listenning on port 5060

Hello,
I have a problem with vesions 17 and 18 of asterisk on Debian, at the end of each install and when I do the netstat -anup command, I have Asterisk listening on many ports (4569 4520 58152 5000 and 2727) but not on port 5060, I cannot connect a SIP account
I tried to add the port to the firewall “sudo ufw allow 5060”, it sdoesn’t work.
Thanks for your help

There really isn’t enough information. The likely reason is that both chan_sip nor chan_pjsip failed to load, which could be due to missing components, broken configuration files and other reasons.

I note that you didn’t even say which of these you were trying to load.

Many of these problems will produce entries in the log files.

You also try manually loading the relevant module, from the CLI.

I am a beginner and prefer to stay with SIP for now
I edit the file modules.conf and I add a ; before noload => chan_sip.so , the Chan_sip module is now automatically loaded and the port 5060 is now open.
I think it is the Sip_chan.so module which is no longer loaded automatically since version 17
Thanks for your help

If you are a beginner, you should start with the PJSIP implementation of SIP, as it is the only one that is properly supported.

Did you, by any chance, use a “cert” version? These do disable chan_sip, as they are intended for people with Sangoma support contracts and Sangoma won’t provide support for chan_sip.

Thank you for your answers
I started with SIP because I found a lot of tutorials which explain the principles and also a lot of requests on the forums.

I downloaded it from https://downloads.asterisk.org/pub/telephony/asterisk/asterisk-18-current.tar.gz and installed it as described in this tutorial https://www.securevoip.io/how-to-install-asterisk-18-on-debian10/