Change default asterisk port 5060 to so

Hi,

Working calling using PJSIP on asterisk 16.0.

Everything is working fine with the port 5060 but after updating that port calls are disconnecting after 30 to 32 seconds.

I do check my NAT and firewall, The port is open and listening.

Any help would be appreciated.

Do you have these settings set on your transport configuration:

external_media_address=<public_ip> ;External Media IP to use
external_signaling_address=<public_ip> ;External SIP IP address to use

It may be that your firewall has an ALG enabled for port 5060 that is not being triggered when you change the port.

Thanks for your prompt reply.

Got the issue.

Issue was in pjsip.conf file.

It’s resolved now.!!!.

Again, Thank you for your time. :slight_smile: