Installation Problem with Asterisk 1.4.1 - Mystery Dot File?

Running on RedHat 7.3 Linux. Downloaded latest tar for asterisk-1.4.1.
Expanded tar, ran configure, and ran make without issue.

Hitting a problem running make install.

Make enters the ‘sound’ subdirectory of my build hierarchy
(/homes/packages/asterisk-1.4.1/sounds) and then complains that I
need fetch or wget enabled to get some required files. Turning on make
debugging reveals it’s looking for something in the file or directory
/var/lib/asterisk/sounds/.asterisk-core-sounds-en-gsm-1.4.6 (notice
the dot). I tried making a dummy directory at this location but no joy.

There is a file with a similar name, asterisk-core-sounds-en-gsm-1.4.6.tar
located in my buildl hierarchy /homes/packages/asterisk-1.4.1/sounds,
so I don’t believe I need to download anything extra.

How do I create this mystery dot file?

i think you’ll probably find it’s looking for the existence of that file to see if you have already downloaded the sound files.

before you run “make”, run “make menuselect” and you’ll see at the end of the list, the soundfile packages you get. obviously, to distribute those with Asterisk source would be silly, so “make install” grabs the ones selected by you (one is default).

can you install wget ? otherwise, download the tarball of the sounds, install them in the appropriate directories (it’s changed in 1.4) and you can either deselect the option in the menu, or use touch to create the file “pointer”.

[edit] the dot (.) just makes it a “hidden” file.[/edit]