Asterisk Installation Error For Sound

please read error below :
Please help me that where i am doing wrong in installation ?..


make -C sounds install
make[1]: Entering directory `/usr/src/asterisk-1.4.23/sounds’

*** You must have either wget or fetch to be ***
*** able to automatically download and install ***
*** the requested sound packages. ***

*** Please install one of these, or remove any ***
*** extra sound package selections in ***
*** menuselecct before installing Asterisk. ***

make[1]: *** [have_download] Error 1
make[1]: Leaving directory `/usr/src/asterisk-1.4.23/sounds’
make: *** [datafiles] Error 2

The error is clear, you need to install wget or fetch to retrieve sound files from the Digium site.


Marco Bruni

Please let me know from where and how to download and install Wget or Fetch. i am new user to linux and asterisk, i hope you will tolerate my stupid question !

waiting to hear from you


well that depends on what distro you are using

apt-get install wget

yum install wget

finnally i have installed asterisk after 3 years effort !!!

bundle of thanks

i am using OS FEDORA 9

trying to download ASTERISK-GUI when i run this command

svn checkout

it gave me error. svn : command not found

please guide what to do…

You’ve have to install the subversion package, try

yum install subversion


Marco Bruni

i have installed asterisk gui from branch 2.0. extract, make and finally install.

after changing configuration file according to tutorial avaialble at digium. it is not yet let me connect to local host.

error : firefox can’t establish a connection to the server at

any idea ?

i have already turn off my firewall

according to these line, configuration is ok. i have turned off my firewall too. would you please tell if there is any other modification required ?

thanks plz

[root@localhost 2.0]# make checkconfig
— Checking Asterisk configuration to see if it will support the GUI —

  • Checking for http.conf: OK

  • Checking for manager.conf: OK

  • Checking if HTTP is enabled: OK

  • Checking if HTTP static support is enabled: OK

  • Checking if manager is enabled: OK

  • Checking if manager over HTTP is enabled: OK
    — Everything looks good —

  • GUI should be available at localhost.localdomain:8088/aster … basic.html

  • Note: If you have bindaddr= in /etc/asterisk/http.conf
    you will only be able to visit it from the local machine.

    Example: localhost:8088/asterisk/static/c … basic.html

  • The login and password should be an entry from /etc/asterisk/manager.conf
    which has ‘config’ permission in read and write. For example:

    secret = dumbass
    read = system,call,log,verbose,command,agent,config
    write = system,call,log,verbose,command,agent,config

— Good luck! —

did you change this bindaddr= to

and you need to change the line
localhost.localdomain:8088/aster … basic.html

"ip adress to you box like":8088/asterisk/static/config/cfgbasic.html