Install error on Ubuntu 12.04 due to libspeex1 dependency


Making and installing dahdi-complete package and also making asterisk version 10.9.0 works ok. But asterisk install fails caused by a dependency violation for the libspeex1 package. Asterisk seems to demand <= 1.1.4 of libspeex1, but Ubuntu 12.04 has version 1.2 installed (including a lot depencenies to banshee etc.).

[quote]Exact error is (translating from swedish to english): libspeex1 is in conflict with asterisk (<= 1:
asterisk (version 10.9.0-1) will be installed.
dpkg: error while managing /usr/src/asterisk/asterisk-10.9.0/asterisk_10.9.0-1_i386.deb (–install):
package conflict - Asterisk will not be installed[/quote]

I’ve followed the guide on this page:
…can also mention that I’m using checkinstall to implicitly create a debian install package upon install. Because this makes it easier to uninstall.

Is it possible to install it on ubuntu 12.04 LTS and in that case how to fix it?




You need to change the version number of the .deb package in order to avoid this conflict. You can create a package with this command:

sudo checkinstall --pkgname=asterisk --pkgversion="1:10.9.0" --backup=no --deldoc=yes --default

Please find the “1:” before the number of the version - this is the clue to success :smiley: