Increase the volume of recorded messages in voicemail


I’m running asterisk 1.8 on a linux box. I notice that the volume of the recorded unavailable message is too low. I use the following command to fix the problem, but that doesn’t make any difference. Any suggestions? Thanks.

exten => 700, 1, VoiceMailMain(,g(9))

I think that only works on DAHDI channels. For other channel types, try the volgain parameter in voicemail.conf.

Setting volgain to 5.0 seems to be the reason that my call gets disconnected as soon as I try to listen to my newly recorded unavailable message.

According to the following comment in voicemail.conf, sox is required.
What is sox? Is it something like a media interface card?

; volgain=0.0 ; Emails bearing the voicemail may arrive in a volume too
; quiet to be heard. This parameter allows you to specify how
; much gain to add to the message when sending a voicemail.
; NOTE: sox must be installed for this option to work.

sox is a command-line application for audio manipulation.