Inbound drops -- need suggestions

I have a strange issue that’s happening on my asterisk “pbx in a flash” server. I’m using"Callcentric" as my inbound provider. This issue only occurs on inbound calls. I’ve experienced this calling my home phone from my cell, work phone on an aspect switch, and calling from other voip phones. When I call my home phone my wife picks up, and we’ll be talking for a few minutes and then all of a sudden on my end I’ll hear this really long annoying tone (as if someone was holding down a key on a touch-tone phone) and then the call disconnects. On my wife’s end on the callcentric home phone will just be completely silent and then the call drops. Outbound calls are fine.

I’m running on a pretty low end system, so I’m not sure if that is what is causing the issue. I’m running it on a PII 400Mhz w/ 256meg ram.

If anyone has any ideas, please respond.

I ran into similar problems with a NAT firewall. Are you forwarding any ports on your router?

I’m forwarding sip ports 4060-4061. how would that cause this issue?

Do you mean 5060-5061?

Cheap consumer routers are not very good at properly routing UDP traffic especially behind a firewall. If the router’s NAT table fills up then it could cause all kinds of interesting behavior. The only reason I suspect it could be a NAT problem is because the problem only occurs after a few minutes which could give a cheap router enough time to fail.

I would be willing to bet you could reproduce the problem by resetting the router (pulling the plug/reconnecting it), making a call and documenting how long it takes to fail (on average). You may see a pattern develop.

I’ve seen this sort of thing with incorrect dtmfmode settings.

Do you have “dtmfmode=rfc2833” set on the trunk?

Yes, I meant 5060-5061. I was hurrying to write the response before I left work. Typo.

It’s not the router. I’m running dd-wrt firmware, plus I used the same settings while I was previously running asterisk@home version. I upgraded to pbx in a box for the extra features and easier configuration. I never had the “long tone” issue on my previous asterisk@home pbx setup.

I may have dtmfmode=rfc2833 as an active setting. I’ll check that out. Anymore ideas would be appreciated.