Inbound Call Issue - 2/3 second delay before call begins

I have a curious problem, I have setup Asterisk on Centos. It’s connected to a ISDN30E (PRI) and then I have a bunch of Cisco 7941s which connect to the Asterisk server using SIP.

When a inbound call comes in over the ISDN30E (PRI), the phone will ring immediately and a couple times a day there is a 2 to 3 second delay before we can hear the voice of the inbound caller?

Below is my dadhi channel configuration:

channel => 1-15
channel => 17-31

I have disabled the fax detection because i thought it might be that…



You are probably losing the first OK from the phone, and having to wait for it to timeout the lack of an ACK and resend the OK. That OK contains the RTP destination for the inbound speech path.

Thanks for the quick reply again, really useful. Do you suspect that there’s packet loss on the network? The phones are connected to the same switch and on a local lan?

That is a possibility. Running an ngrep or ethereal trace on the Asterisk server would confirm or deny that. I would think though if that were the case, you would see some audio quality issues as well, albeit sporadic. Is it the same phone having the problem each time? Same b channel maybe?

Thanks, I’ll run a TCPDUMP on the system and see what I can find. As for the phones, no it’s not the same phone and I think it affects all the phones in the office, certainly the Cisco 79XX series of phones.

I dont want to hijack the thread, but I have a post with the same problem, only it’s outgoing calls that I recently created. Could be related, though our set-ups are quite dissimilar. It may help us both if we watch each other’s threads. Good Luck!

In case it helps, I’ve also tried turning off fax detection, eliminating the jitter-buffer, and removing ‘r’ from the dialing (In Free-Pbx General Settings). None of those have helped me. My phones are all Aastra 57i’s.

No problem at all, I’m still having the problem and looked at the tcpdumps and everything looks clean. Its really frustrating and i think it only affects the inbound calls but i cant be sure, I’m pretty confident though that its to do with SIP and not my PRI.

Have you had any luck?

Sounds like in both cases the echo canceller software doing its stuff.

What you need to do is run rtp debug and see when the stream starts


Thanks, I was reading about that. I’m using:

This file is parsed by the DAHDI Configurator, dahdi_cfg

Span Configuration



Would u suggest a different echo canceler ?