Inbound calls not routing to right extention (Synology NAS)

Hi all,

Summary: two trunks coming from the same VOIP provider always route calls to the destination of one of the trunks, even if the call came from the other trunk.

I’m thinking of moving from my 3CX VOIP server running on Windows Server to a Digium Asterisk VOIP server running on a Synology DS412+ NAS. So far I’ve done the following things:

  • installed XPEnology to test if I can get all the features I run on my Win2k8 server on the Synology NAS, which creates a standard Synology DS3612 virtual NAS (which should work like any other SynoNAS with DSM 4.x), I’m behind a router, so NAT is in place.
  • installed the Synology packages from the package centre (version is Asterisk, which has the Digium GUI (Asterisk GUI-version : 2.1.0-rc1)
  • created two extentions (6000 and 6001), which can receive calls and make calls (using a softphone)
  • created one voice menu (7000) which plays a recording and can be accessed from the extentions
  • created a few trunks, of which two are hosted by the same provider (, which need to be on insecure=very to register at all. The trunks aren’t active anywhere else (but my 3CX server is till runnning, serving other trunks from other providers)
  • created an incoming call rule for each of the trunks, all without a time interval (set to none) and all with a pattern of _! (to match any caller ID?). The first cheapconnect trunk has one of the extentions (6001) as the destionation, the other the voice menu (7000).

Now I have the following problem: when I call any of the numbers assigned to the cheapconnect trunks from my mobile phone, calls are always routed to the voice menu and never to the extention (which is logged in at that time).

How can I me sure the calls to the first ceapconnect trunk go to the extention and to the second trunk go to the voicemenu? I’ve googled a fair bit but came up empty…

For any solutions, I would like to stay away from editing the conf files, if possible. :wink: I do have SSh access and could edit files, but this should be solvable through the gui, right?

BTW, I tried to get debugging going by using the instructions from the wiki: … nformation, but the /var/log/asterisk/ directory (and thus the logfile) does not exist.

You need to contact Synology; they chose to use an out of date and unsupported GUI, so they should take responsibility for supporting it. (Other Synology users suggest that they will not be helful.

Bummer… :frowning:

Would removing the Synology Asterisk version and installing another version with a better gui do the trick? I don’t mind re-configuration, that may even clean up the .conf files a bit (I tried lokking into them, but thet seem cluttered with left-overs).

If so, can you recommend a version+gui and perhaps point me in the right direction for an installation guide? This is my first Synology NAS, so a n00b-version would be nice. :wink: