IMAP Error: Can't open mailbox


I am using asterisk1.4.4, i am trying configure IMAP(dovecot) server with asterisk.

My voicemail.conf looks like this

imapserver =
imapport = 143
imapflags = notls
authuser = balaji
authpassword = password

102 => 102,Rama,,imapuser=ahmed|imappassword=password

where we have to declare the imapuser and imappsword ?

I am getting the below error:

[Jun 11 12:15:47] ERROR[13456]: app_voicemail.c:8493 mm_log: IMAP Error: Can’t open mailbox {}INBOX: invalid remote specification
[Jun 11 12:15:47] ERROR[13456]: app_voicemail.c:4666 init_mailstream: Can’t connect to imap server {}INBOX
[Jun 11 12:15:47] ERROR[13456]: app_voicemail.c:2542 inboxcount: IMAP mailstream is NULL

Thanks in advance


As you should have seen from the other posts, IMAP support is broken in 1.4.4. Many updates have been added to the trunk version and it is supposed to work. However, the crashes are gone and the ability to record messages and send them to the correct folder are OK. I still cannot retrieve the messages with a phone, and I get no MWI. I suggest, you watch the bug reports to know when IMAP storage is stable again.

Just tested asterisk-1.4.5 this morning and IMAP storage works well. I tested with Dovecot 1.0 with masterusers and quotas configured. I tried mbox and maildir formats. All worked well. I still seem to get an email mailed to inbox as well as the desired placed in the Voicemail folder. I will look into this. I did remove the email address from the voicemail user configuration, but it could still be my configuration.