1.4 and IMAP support

Hello all,

I’m trying to test support for IMAP with 1.4.0 on CentOS 4.4. When I do a make menuselect and try to enable Voicemail Build Options and try to select IMAP_STORAGE it has the XXX next to it meaning there are dependencies (specifically imap_tk) that are needed but not installed. I’ve tried finding info on imap_tk but have had no success.

Can someone point me in the right direction?

Thanks in advance for your help!

I was able to get it installed but once I configure the server and user settings I get the following:

[Jan 23 20:49:20] ERROR[3696]: app_voicemail.c:8338 mm_log: IMAP Error: Can’t open mailbox {serverip:143/imap/novalidate-cert/user=nperry}INBOX: invalid remote specification
[Jan 23 20:49:20] ERROR[3696]: app_voicemail.c:4625 init_mailstream: Can’t connect to imap server {serverip:143/imap/novalidate-cert/user=nperry}INBOX

I’ve downloaded and installed c-client from Washington, recompiled * with the --with-imap=/usr/src/imap-2006d option, and reinstalled * with no success. It’s not even hitting the imap server so it seems to be an issue either with * or the imap client itself.

I went through the process on a VM and it worked great. I then replicated the entire process on another server (identically) and it doesn’t work. The two were installed the same and the voicemail.conf and users.conf files are identical.

Any help would be greatly appreciated.


I’m now able to use IMAP storage but only when I manually set each imapuser and imappasswd in the voicemail.conf file for each mailbox. I’d like to generally authenticate to only require the imapuser for each mailbox but I get a Login aborted each time.

My IMAP server is MS Exchange 2k3 and IMAP works for clients, but not for exchange.

Can someone point me in the right direction?

Anybody have been able to get it to work ?

I have Asterisk, Exchange 2003.

If I try to leave a message in a mailbox I have :

[Jun 1 12:05:41] ERROR[493]: app_voicemail.c:8740 mm_log: IMAP Error: Login aborted
[Jun 1 12:05:41] ERROR[493]: app_voicemail.c:4789 init_mailstream: Can’t connect to imap server {}INBOX
[Jun 1 12:05:41] ERROR[493]: app_voicemail.c:2485 messagecount: IMAP mailstream is NULL
[Jun 1 12:05:41] NOTICE[493]: app_voicemail.c:2999 leave_voicemail: Can not leave voicemail, unable to count messages

If I use mtest to test the connection I get :


It ask me for the password of the user then it just work.

Here are my revelant config :


215 => 5555,Test,test@bXX.XX.CA,imapuser=test|imappasswd=1234