Icmp unreachable (port unreachable)


this is my sip.conf setting , wireshark shows the error “Icmp unreachable (port unreachable)” .
i tries port=5060 and bindport=5060 as well.
can any body please help ?

The problem with this is that Asterisk generally just works, and you haven’t given any debugging information, or even the version.

For a start, are you sure that Asterisk has actually started?

Either Asterisk isn’t started or you’ve got a firewall in place on the server.

first i started asterisk by this command "root@localhost asterisk# asterisk " then “asterisk -r” terminal shows
Connected to Asterisk currently running on localhost (pid = 2432)

then i stop the firewall by using these commands
"service iptables save"
service iptables stop

but softphones still could not be register , Port unreachable

Use netstat or lsof to confirm that the port is open on Asterisk.

Then use tcpdump or wireshark to see what is reaching the machine.

chan_sip may have failed to load, e.g. syntax error in sip.conf. Do any of the sip CLI commands work? If not, turn up verbosity and manually run “module load sip” to see what errors are produced. You could also look at the logs produced when Asterisk was starting.

by this command "netstat -lu"
output is following

Proto Recv-Q Send-Q Local Address Foreign Address State
udp 0 0 *:bootpc - :
udp 0 0 *:dhcp-failover2 - :
udp 0 0 *:850 - :
udp 0 0 *:sunrpc - :

I ran into this problem after upgrading from Asterisk v1.8.3.3 to v1.8.9.3 with no changes to A* config files or network settings. Server and all phones are on the same 24-bit subnet. It turned out that v1.8.9.3 has NAT turned on by default, while v1.8.3.3 had it turned off, and I had no custom NAT settings in my sip.conf file. Adding nat=off in the [general] area solved my problem. Look for the line “Reliably Transmitting…” while debugging a SIP peer to see if A* is using NAT.

  • Dennis