Asterisk not listening in port 5060

Does anyone knows what could be the cause for asterisk not listening in post 5060 if SIP interfaces is loaded with no problems?

I am using CentOS.

I have followed the instructions in several tutorials and tried several soft phones and the SIP interface seem to be dead.

  1. When loading asterisk SIP load with no problem
  2. When I activate the DEBUG for a peer, ip or sip in general, I don’t get to see any messages when a connection is attempted from any soft phone.
  3. The soft phones all report a timeout when trying to register.
  4. Tried also to move to port 80 that I know is open but still the same problem.
  5. If I telnet from other computer to asterisk server on port 5060, it does´n response

I will appreciate any help anyone can provide with this problem.

what does the sip.conf say about bindaddr bindport and localnet ?


Are you firewalling 5060?

Run Wireshark on the * box to see if you are actually getting any messages from your SIP devices.


and What do you mean with localnet?

I took this information from wireshark.

It seem that the * server is receiving the authentication request from X-lite phone, but the * response with an “destination unreachableâ€

I solved the problem adding the SIP port 5060 on the linux firewall, setting under
"System -> Adminstration -> Security Level and Firewall".
And the Registration was successful.

Ths all!!!