IAX clients and meetme


#1

Hi folks,

I’m currently using Junction Networks as an IAX provider and they are working great!

I’m trying to set up a meetme conference where when you dial in, it goes directly into the conference.

I had this working with asterisk 1.0 rpms (asterisk-1.0cvs20050808-1.i686.rpm, et al) and I’ve since upgraded them to asterisk 1.2 rpms (which I found on rpm.pbone.net)

The only hitch I had with the new RPMs was that zaptel- and zaptel-devices both included two files for /etc/udev.d (in fact, that’s ALL that zaptel-devices included), and zaptel-kmdl required zaptel-devices, so I rebuilt the rpm for zaptel-devices without any files and it worked.

Anyways:
when I connect to the meetme with my sip client running on several machines (windows, linux, mac) it works, and they’re able to talk. When I dial in from the outside it can listen but cannot speak, even though the ‘m’ option isn’t being passed to meetme.

here are my configs… note that the extension and login information have been modified:

iax.conf

[general]
bandwidth=medium
disallow=all                    ; Icky sound quality...  Mr. Roboto.
allow=ulaw;

jitterbuffer=yes
dropcount=1

register => example:XXXXXXXX@iax.jnctn.net

tos=lowdelay

[jnctn]
type=user
auth=rsa
inkeys=jnctn
context=default

[junction_out]
type=peer
host=iax.jnctn.net
username=example
secret=XXXXXXXX

sip.conf

[general]
context=default                 ; Default context for incoming calls
realm=pbx.gss.us                ; Realm for digest authentication
port=5060                       ; UDP Port to bind to (SIP standard port is 5060)
bindaddr=0.0.0.0                ; IP address to bind to (0.0.0.0 binds to all)
srvlookup=yes                   ; Enable DNS SRV lookups on outbound calls
pedantic=no                     ; Enable slow, pedantic checking for Pingtel
disallow=all                    ; First disallow all codecs
allow=ulaw                      ; Allow codecs in order of preference
externip = 68.169.250.157       ; Address that we're going to put in outbound SIP messages
                                ; if we're behind a NAT

localnet=192.168.0.0/255.255.0.0; All RFC 1918 addresses are local networks

[kitchen]
type=friend
context=from-sip
secret=testing
host=dynamic
nat=no
canreinvite=yes
dtmfmode=RFC2833
mailbox=2203@voicemail

extensions.conf

[general]
static=yes
writeprotect=no

[globals]
CONSOLE=Console/dsp

[from-sip]
exten => _1NXXNXXXXXX,1, SetCallerID(123456789);
exten => _1NXXNXXXXXX,2, Dial,IAX2/example@junction_out/${EXTEN};
exten => _011.,1, SetCallerID(123456789);
exten => _011.,2, Dial, IAX2/example@junction_out/${EXTEN};
exten => 9001,1,Playback(conf-enteringno);
exten => 9001,2,Playback(digits/9);
exten => 9001,3,MeetMe(101);
exten => 9002,1,Playback(conf-enteringno);
exten => 9002,2,Playback(digits/9);
exten => 9002,3,MeetMe(102,,4321);
exten => t,1,Playback(tt-weasels);
exten => t,2,Hangup;

[default]
include => mainmenu;

[mainmenu]
exten => _1XXXXXXXXXX,1,Answer;
exten => _1XXXXXXXXXX2,Wait,2;
exten => _1XXXXXXXXXX,3,Playback(conf-enteringno);
exten => _1XXXXXXXXXX,4,Playback(digits/14);
exten => _1XXXXXXXXXX,5,MeetMe(101);
exten => _1XXXXXXXXXX,6,Playback(vm-goodbye);
exten => _1XXXXXXXXXX,7,Hangup;

I am thinking about rolling back to the old version of asterisk, where it all seemed to work, but I also need the capability to record these conferences, and that feature appeared to be added in 1.2 :frowning:

Any advice would be great, thanks!


#2

oops, forgot meetme.conf… but it’s pretty obvious anyways:

[rooms]
conf => 101
conf => 102,4321

-Jeremy


#3

oh and one more thing… I had configured it at one point so all calls from the outside went straight through to my sip client, and they were able to communicate without any problems.

outbound calls from the sip client also work fine… it’s just when IAX clients go through meetme.

-Jeremy


#4

anyone? :frowning:

-kitchen