MeetMe() not working


#1

I’m using Asterisk 1.2.4 netsec where everything seems to work fine. I can make and receive SIP and IAX calls, transfer and use voice mail. CDR are recorded fine into MySql. However I can’t get conferencing to work. I have this:

-------------------meetme.conf
[rooms]
#include meetme_additional.conf
conf => 600

-------------------extensions.conf

exten => 600,1,MeetMe(600,ipMx,1234)
exten => 999,1,VoicemailMain( )

Since voice mail works fine on extension 999 but extension 600 gives me a “Call failed 603 - declined” message (X-Lite softphone) I can rule out not being in the right context. I’ve been searching around and think that the problem is that the app_meetme.so module is not loaded. If I look for it in usr/lib/asterisk/modules/ (Fedora Core 4) I do not see it.

Has something changed in the way MeetMe() works? Should the module be in that directory?


#2

Sounds like you’ve made the rookie mistake of not compiling/installing Zaptel before Asterisk. I’ve made the same mistake. As I’m sure you know from reading the book (free online version available if you search for it), MeetMe depends on a timing device. If no timing device is found, MeetMe won’t even get compiled. The Zaptel package inludes a timing device. So, to solve your problem, download, compile and install Zaptel. Then do the same with Asterisk.


#3

You are absolutely right! I did rtfm (or in this case: rtfb) but since I don’t plan on using any zapata cards I just skipped that part. Big mistake. Compiling this is easy although tricky. So I got it working.

In my case (kernel 2.6) I had to do:

make linux26
make install

in the zaptel source directory.

Thanks for the hint.

There is another post that may be relevant to someone using an older version. It seems that /dev/zap/pseudo is misspelled as /dev/zap/pseuedo and this causes the “This is not a valid conference number” message. This actually happened to me because for some reason ztdummy and zaptel did not load the first time and so there was no /dev/zap directory. This is the post:

forums.digium.com/viewtopic.php? … ht=pseuedo

I did not have to do any of this.


#4

After some months my server (FC4) rebooted because the UPS could not handle a very long power failure today. I noticed that conferencing was not working (Asterisk 1.2.4) again because zaptel and ztdummy were not loaded. During the last weeks I ran a yum update several times and had a kernel update. It seems that zaptel is compiled and installed in /usr/lib in the subdirectory of the kernel you are running when you compile. So if you update a kernel, the module is not found. I solved this by recompiling and reinstalling zaptel (1.2.3). I did not have to recompile Asterisk itself. I hope this bit of information helps someone with the same problem.