HP Dual Core - Zaptel Loaded but Asterisk says no zaptel

I’ve been using asterisk for a long time, and had to migrate to a new pc due to hardware failure.

Currently used Fedora 8, with latest Zaptel and Asterisk with no problem.

Installed Fedora 9 onto new HP Dual Core, and everything loaded ok.

Zaptel tool says channel found, and /dev/zap exists etc. Still using latest 1.4 version of asterisk

But when i try and start Asterisk is says no zaptel device found. Looking at the source it code refers to ‘no timing device’ found - but zaptel is loaded and running.

Also tried asterisk 1.6 beta - with same result

Does anyone have any ideas ?

Is there anything different about running Zaptel/Asterisk on dual-core ?


Every one of my servers are running dual core intels.

Are you sure that you have the correct headers etc.


i have just followed the same process as before, with the kernel-devel and kernel source.

Is there something specific for dual-core ?

im asuming that fc9 is similar to centos 5 and all kernals support smp procs so there is nothing different.

You did complile in the correct order ? IE zaptel first then asterisk
and if you have are loading ztdummy ? what does zttool show?


the fedora 9 kernel doesn’t appear to have smp sources - i’ve had to go for a new server (hence went for dual-core), my current ‘server’ is fedora 8 on a P4, and is working OK - except the occasional controller error - hence the move to a new server.

I’ve only ever loaded the zaptel driver before and never needed to load ztdummy as well.

zttool shows a configured and ‘OK’ zaptel device/card - even the other ztmonitor/etc tools all appear to show the device.

Hi I would recompile in the correct order. and see what happens.


i have installed src and recompiled a number of times so far - each time completely removing the source and rebooting etc.

Read somewhere last night that asterisk does/did not like SATA disks - this new server hardware is so different to my current one.

made some progress this morning.

I am using an X100p card, so that I can use the patches to use UK Callerid.

Asterisk won’t take on these patches so I have to apply them myself.

I did have a digium WDM01B single FXS card, but never managed to get it to work.

This morning I took out the X100P card and put in the TDM400P, and it is recognised by asterisk.

All I need to do now is get the generic callerid to work on this card, or see if the x100p (usehistory) patches will work too.

Does anyone have a WDM01B card working with UK Callerid ?

as usual, following a reboot, zaptel configures ok, but now asterisk says that zaptel is not there or mis-configures.

So back to square one again.

Looking at google there are people mentioning problems with zaptel and dual core, but they don’t say what the fix is, as usual, to stop this happening.

try to see asterisk log file. if u see any error on zaptel.conf file try to fix it. i m using digium and sangoma with quad core dual xeon, its working fine.

had to resort to rebuilding my voIP environment elsewhere.

Got an old P2 2gm memory, and build fedora 9 on there and installed zaptel and asterisk and surprise - worked first time.

Did notice however, that on the dual core, the Zaptel was reported on OK test on the line, and there was no telephone line plugged in.

So not sure whether it’s a problem with the HP dual core box, or whether Zaptel and fedora 9 is not working properly.

A backwards step - but at least it’s working in fedora 9 on an old box ! not sure whether it’s dual core or SATA drives, or hardware which is stopping it working.

I am leaving Zaptel running on the Hp dual core, to see when it reports a RED alarm for Zaptel.