How to setup asterisk to uses localtime instead of UTC


#1

I am running asterisk 11 on a Netgear R7800 router under dd-wrt firmware.
Asterisk PBX 11.25.3 running under
Linux DD-WRT-ROUTER2 3.18.77 #181 SMP PREEMPT armv7l DD-WRT. 12/2017.

I cannot figure out how to make asterisk to uses local time. It always put the UTC stamp on every thing it produce such as log files, vm files, alarm receiver files from ademco, etc.

The router is setup for US EST and I have already tried changing to different timezones and locale from Asia and Europe. Not matter what timezone I set asterisk always uses UTC.

I know the linux box is set correctly and all the system log files are using the localtime setup on TZ.

There must be and undocumented global variable somewhere similar to cel.conf:usegmtime.
This variable define the behavior that I am looking for but unfortunately is not a global setting.

Any feedback or ideas will be appreciated.