How to move Asterisk installation to new hardware

I have been using Asterisk for a while now, and It has been running flawlessly. The PC is now getting a bit old and has shown signs of failure, so I want to move the Asterisk installation to a new computer. I bought one, and I have installed the same Asterisk version than I have on the current computer. Of course, all the configurations I have done over the years must be transferred over (Trunks, Extensions, IP addresses, IVRs, voice prompts, messages, etc.). Can someone point me to a resource that describes how to do that?

Assuming it’s the same version

Transfer the contents of /etc/asterisk /var/spool/asterisk /var/lib/asterisk to the new server.

Thanks, that’s good advice. I tried to install the same distro on the new PC I set up, but I think that it may be a bit old. I think it is Asterisk 1.6 or 1.7 and FreePBX And I think it is a 32-bit version. I think it may be time to use a different distro and run that in 64-bit. So, how would I go about that? Should I upgrade the old box to the new distro, but 32-bit, and then transfer the files? How would I actually upgrade Asterisk and FreePBX? I think I tried that once and it failed. I just checked the online upgrades, and it shows me that FreePBX 2.9 is available. Would that be the same one I get with a new distro of AsteriskNow?

Alright. I now have one (working) Asterisk box with an old 32-bit system, and a new Asterisk box with a new 64-bit system (Asterisknow 612). What now? How can I bring over the setup? Should I try to just copy the contents of the directories above?

Ah, You did not state you were using FreePBX.

You will need to ask this question on the FreePBX Forums at

FreePBX would be totally different than doing this with a standalone asterisk install.

Thanks. I’ll see what they have to say :slight_smile:

Sorry, does someone have access to the FreePBX forum? I can’t log in there, and I can’t create a new login. All I get is a message that says: “Sorry, there was an error authorizing your account. Perhaps you did not approve authorization?” I have tried 3 times to set up a new account and never received any “authorization request”. I have tried IE, Firefox, and Chrome. All the same. And there is no contact where I could go to get help on this or report this problem. Catch-22?

Maybe their email to activate your account ended up in your spam folder?

Try a different email perhaps if not?