How can i disable the Directory? i.e. #


#1

Hi, anyone know how i can disable the directory feature for incoming callers? i don’t want people to be able to call extentions by knowing the persons name. However, i still want them to be able to dial extentions by extention numbers. im using asterisk@home version 2.2


#2

i’m assuming you mean the directory application while in a “Digital Receptionist” ?? if yes, go look at the extensions_custom.conf file, find the [aa_xxx] context (where xxx is a number) and you can work it out for youself :smiley:


#3

i found the aa_1 in the extentions_additional.conf. i don’t know which line to rem out. should i just remove the app-directory include statment? heres my aa_1 section, know which line to rem off hand?:

[aa_1]
include => aa_1-custom
exten => fax,1,Goto(ext-fax,in_fax,1)
exten => h,1,Hangup
exten => hang,1,Playback(vm-goodbye)
exten => hang,2,Hangup
exten => i,1,Playback(invalid)
exten => i,2,Goto(s,7)
include => ext-local
include => app-messagecenter
include => app-directory
exten => s,1,GotoIf($[${DIALSTATUS} = ANSWER]?4)
exten => s,2,Answer
exten => s,3,Wait(1)
exten => s,4,SetVar(LOOPED=1)
exten => s,5,GotoIf($[${LOOPED} > 2]?hang,1)
exten => s,6,SetVar(DIR-CONTEXT=default)
exten => s,7,DigitTimeout(3) ; Asterisk Greeting
exten => s,8,ResponseTimeout(7)
exten => s,9,Background(custom/aa_1) ; Please leave a message at the beep, thank you.
exten => t,1,SetVar(LOOPED=$[${LOOPED} + 1])
exten => t,2,Goto(s,5)


#4

ok i think i got it working. i remarked out the include => app-directory line and the exten => s,6,SetVar(DIR-CONTEXT=default) and then corrected the line number sequence.

its working just how i wanted, the user can still enter an ext. but can’t press #.

is this perhaps going to cause other parts of my asterisk box to break? im pretty new to asterisk, obvoulsy, and i don’t want to just start remarking random code :smile:

if not, thanks for pointing me in the right direction!


#5

actualy can you point me in another direction please? how can i get it to transfer to a specific voice mail box if they don’t press an extention? right now it just plays my auto attendents message twice and then hangs up. i can probably figure out how to remove the loop so it only says it once, but how can i then forward that call to a general mailbox?


#6

ok, think “timeout” and follow the logic.

the line exten => t,1,SetVar(LOOPED=$[${LOOPED} + 1]) exten => t,2,Goto(s,5) increments the LOOPED counter before repeating the menu. change these lines (comment them out and write others)

exten => t,1,Voicemail(u200) exten => t,2,Hangup()
which will do “unavailable” voicemail for 200. that help ?


#7

Do you know off hand how to get voicemail() not to say please leave a message? I would rather use a custom recording for that. i started writing my own custom context. i think i will learn more if i do it that way too… if you don’t know off hand i’ll just go dig around in the voicemail() sub. no worries, i need to learn how to do this anyways… thanks again!


#8

ok, i’ll tell you what i know :smiley:

use the ‘s’ option for ‘skip’. todays top tip is

and asterisk*CLI show applications


#9

Coolness! that worked great, and now i know how to figure out the commands using the show application command. Thank You!