[HELP] Zaptel error: Unable to create channel op type 'Zap'


#1

Hi,

In struggeling with this problem for a two weeks now.
I have a X100P clone card in my * box but I’m not able to get it to run.
I’m running fedora core 3 with kernel 2.6.12-1.1372_FC3 on a VIA EPIAML500EA

The compiling of both zaptel and asterisk went without any errors.
I can run zaptel and asterisk without any errors.
When I run ztcfg I don’t get any errors too.
If I run ztmonitor there is no signal comming in.

When I try to place a call trough my x100p I get this error message in asterisk:
NOTICE[4160]: app_dial.c:1091 dial_exec_full: Unable to create channel of type ‘Zap’ (cause 0 - Unknown)

Outside calls are not comming in either.

Here are my zapata.conf and zaptel.conf:


-zapata.conf-
[channels]
signalling=fxs_ks
context=incoming
channel=>1

-zaptel.conf-
loadzone = nl
defaultzone=nl

fxsks=1


The funny part comes here:
I’m installing a *box for a friend with a ISDN card and the same problem occures.
So I probarbly doing something wrong in fedora…

Any ideas???

Thanks,
Peter


#2

Hello, I had this same issue on the most recent version on the CVS tree. I downloaded a stable CVS version and had no troubles after that.

Hope that helps…


#3

I’m not really an expert in linux (yet). :wink:

What is it your suggesting: installing an older asterisk or zaptel
Or installing an older version of CVS?

I already tried installing an older version of asterisk and kernel.
On the isdn *box I installed kernel 2.6.9 with asterisk 1.08.

That didn’t help: still same problem… :cry:


#4

what happened ?
have you solved the problem?
how?


#5

What the exact problem was is never solved.

I configured a new box on which I installed CentOs.

All my problems were solved.

I guess the combination of Fedora and that specific version of Asterisk was the problem…


#6

I installed Federo Core 4 and FreeBSD, and had difficulting compiling the digium drivers into the kernel. I followed the instructions from digium’s website with no luck. I used Asterisk@home (centos) and it solved all the problems. All newbies (like me) should use Asterisk @ home, its so easy to use!

  1. download the asterisk@home iso (500 megs) and burn on cd
  2. pop it in your cd rom drive with a empty harddrive
  3. format the hd, install it and asterisk is ready to go!
  4. in windows, you can access your gui by going to 192.168.0.40!

Why don’t they make Asterisk@home for Windows?