[Help] Voicemail login problem


#1

I’m using the voicemail set-up from this site astguiclient.sourceforge.net/scr … stall.html and is using extension 8500 for the voice mail. Now I can going in the voicemail and when it asks me the mailbox I enter my extension and for the password is the same (as far as I know) and is telling me that the log-in is incorrect. Am i doing something wrong?


#2

I assume the following from the link

voicemail.conf
[default]
102 => 102,Grandstream Mailbox,root@localhost
2000 => 2000,Sipura Mailbox 1
2001 => 2001,Sipura Mailbox 2

102,2000,2001 are htese the numbers you tried? if so make sure they are in voicemail.conf


#3

[quote=“rusty”]I assume the following from the link

voicemail.conf
[default]
102 => 102,Grandstream Mailbox,root@localhost
2000 => 2000,Sipura Mailbox 1
2001 => 2001,Sipura Mailbox 2

102,2000,2001 are htese the numbers you tried? if so make sure they are in voicemail.conf[/quote]

Well it is, the only diference is that I changed the config according to my extensions. Here is my config:
[default]
102 => 102,Grandstream Mailbox,root@localhost
4281 => 4281,Grandstream Mailbox
1709 => 1709,Grandstream Mailbox
1418 => 1418,Grandstream Mailbox
1199 => 1199,Xlite Mailbox 1
1412 => 1412,CiscoATA Mailbox 1

I don’t have a problem accessing extension 1199 and 1412 but the Grandstream phones I can’t.


#4

Try changeing mailbox name like this

102 => 102,Grandstream1
4281 => 4281,Grandstream2
1709 => 1709,Grandstream3
1418 => 1418,Grandstream4


#5

[quote=“rusty”]Try changeing mailbox name like this

102 => 102,Grandstream1
4281 => 4281,Grandstream2
1709 => 1709,Grandstream3
1418 => 1418,Grandstream4[/quote]

Still the same. Do you think it has to do with the extensions.conf?


#6

I don’t have a problem accessing extension 1199 and 1412 but the Grandstream phones I can’t. See if you can acccess these mailboxes from the grandstream .

Are extensions in same context in voicemail and extensions .conf?


#7

Ok. I called Grandstream and found out that it was the DTMF setting that it was on audio and needs to be in via RTP (RFC2833). Now is working,

Thanks


#8

:smiley:


#9

Now if I call any of these extensions and the voice mail systems picks up, once you hear the tone for you to leave a message it hangs up and does not allow me to leave a message. Do you think that has to do with Asterisk configuration? Because I’m looking in the configurations and I don’t see anything wrong and before we had the Grandstream phones we were able to leave messages with no problem.


#10

There are some setting in voicemail.conf for silence detection and minimum message lenghts and such you might want to check them


#11

I checked those settings and still doing the same thing. anyways tomorrow is another day.