[HELP] Broadvoice incoming calls work on and off


#1

I have setup Asterisk@Home v1.5 and for the past few days I’ve been trying without success to keep my Broadvoice.com account to send incoming calls to my * box. It seems to run fine for a while, then I’ll call it and it will ring 5 times and go to BV vm or go directly to vm without ringing at all. I’m nearly positive that I have a config issue, but I just can’t pin down the problem. If I reload my config I can again receive incoming calls. I have even noticed that if I make an outgoing call, then call my number, my server picks up. It’s all very strange, it’s like BV forgets about my registration. Has anyone else noticed this behavior?

Here’s my [BV] entry in sip.conf:
[BV]
authname=<10DigitNumber>
canreinvite=yes
context=from-pstn
defaultexpirey=1800
dtmf=inband
dtmfmode=inband
fromdomain=sip.broadvoice.com
fromuser=<10DigitNumber>
host=sip.broadvoice.com
insecure=very
maxexpirey=300
nat=1
qualify=2000
secret=
type=peer
user=phone
username=<10DigitNumber>

My [General] section:
[general]
port = 5060
bindaddr = 0.0.0.0
host=
disallow=all
allow=ulaw
allow=alaw
defaultexpirey=1800
maxexpirey=300
qualify=2000
context = from-sip-external
callerid = Unknown

My register line:
register=<10DigitNumber>@sip.broadvoice.com::<10DigitNumber>@sip.broadvoice.com

Hopefully that’s all the pertinent sections. Thanx for any suggestions.

-Mike


#2

Broadvoice is one of the few companies that directly supports Asterisk installations.

Click here for information about Asterisk/Broadvoice setup. They’ll also help you directly through their customer support.

broadvoice.com/support_install_asterisk.html


#3

I did follow those instruction when I initially setup my account. Though I did find one setting (pedantic=no) missing from my general settings, I still lose incoming calls until I reload. I’m thinking I should just setup cron to automatically reload asterisk every 30 minutes or so. Is anyone doing this? Might other problems appear if I did that?


#4

I’ve got the same issue. I’m running *@Home 2.1 and have not been able to keep BroadVoice up and running for any length of time. I have my BV trunk running into a AutoAttendant.

Watching the CLI - * says that it’s answered the call and is playing the auto-attendant recording, etc. But it really hasn’t picked up the call. Eventually it all times out and hangs up.

I’ve searched all over and can’t come up with a solution. If anyone knows of one please let me know.