Hang up delay issue


#1

Help Guyz! I’m from Malaysia. But i tried a lot of guides out there in order to get my PSTN disconnected when the caller hangs up but to no avail. Is there anything that i could do to make it more responsive to the hangups? So far i’ve tried :-

  • loading diff zone in zaptel.conf “loadzone=us”, “loadzone=uk” or …
  • I even loaded “opermode=MALAYSIA” for the fxo cards. But this even not responsive enough to the hangups.
  • I even tried putting “callprogress=yes” and “busydetect=yes” but … failed.

Is there any way that i can do to solve the hangups problem? Thankz Everyone.


#2

what signalling is your telco using, and what build of Asterisk are you using ?

it’s not worth guessing with the telco, call and ask them unless you’re 100% sure. it makes all the difference. then you’ll have somewhere to start from (and us too !)


#3

Do i need to know wat signalling my Telco uses? How do i know that? Should i call my local telco about it? Is that really important? I’m a bit noob in this signalling thing on PSTN. Help guyz!


#4

seriously, i wouldn’t have asked if it wasn’t important. and it wouldn’t be an option in Asterisk if it wasn’t important. if you want to be able to detect remote disconnects then yes, it’s important.


#5

If i got the signalling type … then what should i do? Do i need to apply it on the fxo modules or something? Thankz guyz!


#6

yep, your FXO setup needs to reflect the signalling type. what is it btw ? what options are you passing to wctdm at load now ?

IME, remote hangup has been the hardest part of an Asterisk installation, if only because there doesn’t seem to be a set way of doing it. the card suppliers even suggested i change signalling type “just to try it”.


#7

i just added the

"options wctdm opermode=MALAYSIA’

in /etc/modprobe.d/zaptel a line before the

“install wctdm /sbin/modprobe --ignore-install wctdm && /sbin/ztcfg”

and i changed the signalling from fxsks to fxsls