GSM Autodialier on Ubuntu?


#1

I am putting together an appointment reminder server and have really struggled to get it off the ground. I tried the OpenVox G400E, and the ATCom AXEG4N, and eventually got it working for SMS only using an OpenVox appliance, but that won’t let me place the calls with a recorded message like “You have an appointment at 1PM, press 1 to confirm” which will be scripted by PHP, so I am back to trying to get the PCI cards back up and running.

I started yesterday again with the ATCom card, and put together a CentOS 6.0, which through the documentation got upgraded to 6.9. The drivers and files on the website (which I usually use rather than physical media as it is usually the most current) didn’t work at all, but using the drivers on the CD it shipped with I got Dahdi to recognize it (eventually), but then when doing the next part “cat /proc/interupts” I didn’t see that it had worked. ATCom’s instructions says to then try a different PCIe slot, which of course I didn’t have in the HP 360 server.

I pulled out an old SuperMicro server and tried to get it to work there, but no luck again. I am now trying to get it working on a Dell r610, but I am running out of servers to test with, unless I can get it to work on Ubuntu where I have another dozen servers I can play with.

We are still in development, and this server may get relocated, so the GSM seems like a good option, but I can’t see anywhere that anyone has done this on Ubuntu.

Has anyone done GSM on Ubuntu? This is my first Asterisk server (not counting the appliance that runs a stripped 1.6 version), so I am still learning whether I am troubleshooting Dahdi, the GSM drivers, if the GSM drivers are part of Dahdi, if so why isn’t it detected.

Is there a better brand than OpenVox or ATCom? Sangoma, other?

As an aside, how important is it for what I am doing to run a more current version of Asterisk? I see a lot of “current” things being sold with really old versions.


#2

I suggest use Digium Cards, and Hardware support is not provided through this forum

Use the Asterisk LTS version, so you will be running an updated product and with less bugs


#3

Alas, we don’t build a GSM card.


#4

Instead using Ubuntu…try to config mb bios freeing interrupts for your card…
Centos is always to prefer as Linux distro for Asterisk…


#5

I dont see any issue using Ubuntu, I has been using Ubuntu Server for years, and also based on this post made by > @mjordan Asterisk runs on Linux. Digium team test on CentOS 6 and Ubuntu 14.04. So there is no issue if is Ubuntu 14.04


#6

Thank Malcolm, I did look into buying one by your company and was disappointed not to find one. I don’t have a single land line in my life so using GSM just seemed like the thing to do.

I will look into freeing interrupts, the server doesn’t have anything else in it but the raid card. At the end of the “make config” of Dahdi complete, I get this:

List of detected DAHDI devices:
pci:0000:05:00.0 axe4gn- d161:b200 ATCOM AXE4G/AXE2G4A

But the next steps fails:
dahdi_genconf
Empty configuration – no spans
Empty configuration – no spans
/usr/sbin/dahdi_genconf: Failed to open /etc/asterisk/dahdi-channels.conf: No such file or directory

lcpci shows me this:
05:00.0 Communication controller: Digium, Inc. Device b200 (rev 02)

So I am not sure whether I am troubleshooting an interrupt problem, or something else but will try any suggestions.


#7

Yeah, the reason that card shows up as “Digium” is because ATCOM has decided they can just squat on our PCI Vendor ID, 0xd161, that we registered w/ the PCI-SIG. That’s really, really bad form. They do it because they want some of their clone cards to look like some of our old cards, so that DAHDI drivers just load the card as though it were an actual Digium card.

Again acknowledging that Digium doesn’t manufacture a GSM card, and for any other readers of this thread, remember that next time you buy from a cloner. Buying from a cloner takes dollars away from the ongoing development and maintenance of Asterisk. The bill to run these forums isn’t footed by cloners.