Grandstream HT503 y SIP account


#1

Hello I want to make call from a sip account to PSTN network and for that I have a grandstream HT503.

What I means is from a softphone makes call to PSTN network. So for that I created a SIP’s account

this is the sip.conf for that account:

[pstn]
type=friend
host=100.64.0.7
secret=123456   ;contraseña para el registro del usuario al asterisk
context=users
qualify=yes
nat=force_rport
dtmfmode=inband
fromdomain=100.64.0.7

100.64.0.7 is the HT503 IP

this is the extension.conf for that account

exten => { x+ | *x+ | *xx*x+ },1,Dial(SIP/pstn,60,D(wwww${EXTEN}))
exten => { x+ | *x+ | *xx*x+ },2,Playback(all-outgoing-lines-unavailable)
exten => { x+ | *x+ | *xx*x+ },3,Hangup()

This is what PBX gets in CLI when I try to register a softphone with that sip account.

[Nov 10 21:57:13] ERROR[3759]: chan_sip.c:17817 register_verify: Peer 'pstn' is trying to register, but not configured as host=dynamic
[Nov 10 21:57:13] NOTICE[3759]: chan_sip.c:28684 handle_request_register: Registration from '"pstn"<sip:pstn@100.64.0.2:5060>' failed for '100.64.0.3:53967' - Peer is not supposed to register
[Nov 10 21:57:13] ERROR[3759]: chan_sip.c:17817 register_verify: Peer 'pstn' is trying to register, but not configured as host=dynamic
[Nov 10 21:57:13] NOTICE[3759]: chan_sip.c:28684 handle_request_register: Registration from '"pstn"<sip:pstn@100.64.0.2:5060>' failed for '100.64.0.3:53967' - Peer is not supposed to register

And this are the FXO port configuration:

What I doing wrong?


#2

If you re going to use the HT503 as a trunk you dont need to register to Asterisk, there is a setting on the HT503 to disable the registration. also set type to peer instead of friend, I have a long time without used that device, but I managed to make it work a long time ago, follow the link,

https://pastebin.com/vBVUFMhz


#3
  1. As noted, sip registration should be set to no on the gateway (or, less secure, host should be set to dynamic, on the Asterisk side);

  2. “{ x+ | *x+ | xxx+ }” is totally garbled as an extension pattern in Asterisk. It looks as though you have not understood the basics of Asterisk dialplans, and have tried to use information relating to what the gateway calls dialplans.


#4

following what ambiorixg said I configured FXO to do not register in the PBX. But, what I must set up as peer? because is the FXO doesn’t register. I don’t understand that.

So, I don’t need to set up a sip account for call to PSTN (every account can dial to the external numbers)?

david551

First I set up this dialplan _15XXXXXXXX which it’s for a cellphone in argentina. But everytime I set it to grandstream it generate it { x+ | *x+ | xxx+ } . I don’t know if it’s a way to hide it.


#5

I don’'t understand. You should be editing the Asterisk dialplan using a plain text editor, which will put in the file exactly what you enter.


#6

thats in grandstream FXO configuration web page. I want to set up the dialplan there and when I applied the changes it always show me { x+ | *x+ | xxx+ }


#7

That’s between you and Grandstream!

The problem I pointed out is that you have the same pattern in the Asterisk dialplan!


#8

It has to be different?


#9

This is the CLI output when I try to call from julian’s sip account

*CLI>   == Using SIP VIDEO CoS mark 6
  == Using SIP RTP CoS mark 5
    -- Executing [155253687@users:1] Dial("SIP/julian-0000000a", "SIP/pstn,60,D(wwww155253687)") in new stack
  == Using SIP VIDEO CoS mark 6
  == Using SIP RTP CoS mark 5
    -- Called SIP/pstn
    -- SIP/pstn-0000000b is ringing

But it just ring and the call never goes through


#10

Yes. That has no useful meaning to Asterisk. You need to read and understand extensions.conf.sample and the relevant parts of http://www.asteriskdocs.org/


#11

I would use the standard way of dialling on a SIP PSTN “trunk”.


#12

I works in asteriskNow with freepbx. Configuring a sip trunking and a outgoing routes. But I don’t know how to configure it in asterisk frameworks, without freepbx