Getting Error when trying to install Dahdi

Hi,

Currently I’m trying to install dahdi i.e. dahdi-linux-complete-2.4.1.2+2.4.1. After entering ‘make all’ command I’m getting an error which is listed below;

You do not appear to have the sources for the 2.6.18-164.el5 kernel installed.

Even I’ve updated my kernel as well which is listed below;

kernel-2.6.18-128.el5.x86_64
kernel-debuginfo-2.6.18-128.el5.x86_64
kernel-2.6.18-164.el5.x86_64
kernel-devel-2.6.18-128.el5.x86_64
kernel-debuginfo-common-2.6.18-128.el5.x86_64
kernel-devel-2.6.18-238.9.1.el5.x86_64
kernel-headers-2.6.18-238.9.1.el5.x86_64

Please advise at earliest, which other packages I’m missing.

Note: I’ve also installed all packages which are reqiured for installation i.e. gcc, gcc-++, etc.

kernel-devel-2.6.18-[color=#FF0000]164[/color].el5.x86_64

Are you saying that I’m missing: kernel-devel-2.6.18-164.el5.x86_64? But after updating, it loaded kernel-devel-2.6.18-238.9.1.el5.x86_64

Please advise.

kernel-devel must match the version of the kernel that you are actually running. You appear to have installed a later version, but not booted into it.

You must either boot into the newer kernel before building, or have the older kernel-devel available (and continue to boot into the older version).

Thanks for helping me out. Now it installed perfectly