Garbled Sound

Hi All,

I am just a newbie to Asterisk. I have configured the following dialplan for test purpose.

exten => 101,1,Answer(101)
exten => 101,2,Playback(number-not-answering)
exten => Hangup

The problem is when I dial 101 from any other extension, I hear a sound file “number not answering” but it is “GARBLED”.
What do I need to do to eradicate this problem??
I am waiting for your help in this regard.


What format is the sound file that you’re playing? I’ve had better luck with wav than gsm

I am using gsm format.

But for wav would you tell me what sampling rate and bit rate and stereo or mono should i select.


AFAIK, the standard is 8000 mono

To be more specific the wav file format for asterisk is 8000 Hz , 16 bit Mono

I have tried it but the problem is still the same.

I have also loaded ztdummy, libpri and zaptel but its of no use.

Does the problem of “Garbled Sound” has anything to do with the system specifications.

I am running asterisk on Vmware.


VMWare certainly does help to garble sound. You need to ensure it has adequate resources, enable VMWare tools and enable the clock support within VMWare tools, then start looking for some real hardware on which to run your real time applications. VMWare is not intended for strong real time applications.