I have one x100P card.
I tried to tune it with
fxotune -i 4

[quote]Tuning module 1
Skipping non-TDM / non-FXO
/dev/zap/2 absent: No such file or directory
/dev/zap/3 absent: No such file or directory
/dev/zap/4 absent: No such file or directory

/dev/zap/251 absent: No such file or directory
/dev/zap/252 absent: No such file or directory
fxotune: successfully set echo coeffecients on FXO modules
Is this normal?

is it normal … no. here’s the output of fxotune on a TDM01B :

Tuning module 1 ................................Done! /dev/zap/2 absent: No such device or address <snip>

does the module work otherwise ?

in fxotune.c … [code] * fxotune.c – A utility for tuning the various settings on the fxo

  •  modules for the TDM400 cards.[/code]

wonder if that’s the problem ?

That’s true.
That is what it says in /usr/src/zaptel/fxotune.c

Is there another way to tune the x100p card?

given the age of the design, i doubt you’ll see much code anywhere for it. have you used ztmonitor to set your gain levels for the channel ?

Yes, I have used ztmonitor to adjust the gain levels.
It does help me when I tweak the rxgain and the txgain.

But the main problem is the persistent echo of my own voice.

I have tried:
In the BIOS setup, disabled the serial ports, the parallel ports and the USB ports.
And, physically disconnected every RJ11 connection except the one to the x100P line port.
And, followed the suggestions in kb.digium.com/entry/1/1/
And, followed the suggestions in austechpartnerships.com/foru … php?p=1095 except for the fortune part.
And, followed the suggestions in aussievoip.com/wiki/index.php?page=EchoInfo to use ECHO_CAN_MG2 option.

But nothing is working. I still get the echo of my own voice.
Calls between extensions do not have any echo.
I concluded that the x100p is the culprit.
So I thought maybe I’d tune the x100p but that is not an option either.

What else can I do?

sell it, and buy “proper” hardware … either a Sangoma AFT200 or a Digium TDM400.

or go totally VoIP and get a DID from an ITSP.


I have the same problem with this card. Where you bought it?

I got the x100p card from x100p.com/products_1.htm

So we have the same card and the same problem. Fxotune doesn’t want to work with my card, mayby this is only fxotune software issue - i don’t know.