Forward Call to another number with menu


#1

Ok heres a good one for you

Our company resells cellular service. I was trying to setup asterisk with a menu 1 for sales 2 for tech support 3 for billing

1 goes to my sales people
2 and 3 i was goimg to send it out to the 800 tech support line of the cellular company
Eveything wroks great except the cellular company has a menu also and when I call threw the * box there menu doesnt hear the dtmf you cant get threw their menu

Ive tried this to another system one of the satalite companys and it worked great just not with the system the cell company uses

The call coming into * box are on a PRI and have tried to send it back out both PRI and IAX provider

if anyone has any ideas please let me know because im stumped on it


#2

Well, since PRI doesn’t usually use DTMF for signalling, it’s probably due to the fact that the digits you are sending are just winging through the D-Chan as data.

If the IVR at the far end was on a PRI itself, it would be fine. But if it’s not, then it can’t receive the digits and do anything with them.

You might try building a little macro that would dial the distant IVR, and use the Playtones command to generate the touchtones to break through the IVR menus to be queued for a help agent.


#3

Dont think thats the case if it was I wouldnt be able to dial any company threw my PRI and use their menu.

I can call the 800 number of the company from my desk wich goes to the * box out the pri to the PSTN and the menu works fine but if i call say from my house or cell phone to my * box then the asterisk box dials out on the pri to the pstn and connects to the company then the menu does not work.


#4

If you call from a phone connected to the Asterisk box to a distant IVR, the touch tones you send are coming from the phone you are using. Not the Asterisk software. So, it’s not really the same.

I’d expect a call from a phone to work in all cases.

Could you post a copy of the command you are using to dial the distant IVR? I’d like to see what you are trying to make the software do.


#5

Thanks for the replys :laughing:

All call to office number start in hq,s,1
I am trying to be able to press 1 goes to cell context this works takes me to cell,s,1 and plays another menu in cell contex
menu is
press 1 for sales
2 for billing
3 for tech support
when I hit 2 or 3 it Dials the Cell companys 800 numbers but when I press numbers for their menu it does not hear them

I even tried making 2 and 3 got another context that then dials cell company 800 number but still didnt work. I have aslo tried sending the call via IAX connection to my Long distanve provider and got same thing

[hq]
exten => s,1,Answer
exten => s,2,ResponseTimeout(35)
exten => s,3,Background(welcome)
exten => s,4,Background(menu1)
exten => s,5,Wait(5)
exten => s,6,GoTo(hq,s,3)
exten => 0,1,Background(directory)
exten => 0,2,Background(replay)
exten => 0,3,Wait(5)
exten => 0,4,GoTo(Cell,1,1)
exten => 1,1,GoTo(Cell,s,1)
exten => 2,1,GoTo(2way,s,1)
exten => 3,1,GoTo(internet,s,1)
exten => 4,1,GoTo(pageing,1,1)
exten => 5,1,GoTo(satalite,1,1)
exten => 9,1,GoTo(Cell,1,1)
include => office

exten => s,1,ResponseTimeout(15)
exten => s,1,Background(menu2)
exten => s,3,VoiceMail(b710)
exten => s,4,Hangup
exten => 1,1,Dial(Zap/25&Zap/30&Zap/31&Zap/39,40)
exten => 1,2,Dial(Zap/41,15)
exten => 1,3,Dial(Zap/29,15)
exten => 1,4,Dial(Zap/28,15)
exten => 1,5,Dial(Zap/26,15)
exten => 1,6,VoiceMail(b710)
exten => 1,2,VoiceMail(b710)
exten => 2,1,Dial(Zap/G1/18661111111) Cell company 800 number
exten => 3,1,Dial(Zap/G1/18661111111)
exten => 9,1,GoTo(Cell,1,1)


#6

First off… I see a typo.

I think that your cell context should read:

exten => s,1,ResponseTimeout(15)
exten => s,2,Background(menu2) ;<---------------notice the 2
exten => s,3,VoiceMail(b710)
exten => s,4,Hangup

But I don’t think that’s your problem. (At least it SHOULDN’T be.)

Is the G1 group in the same context as the cell context? (Or does it have access?)

When you pass call control from one context to the another, that context has to have access to the resources that are used inside of it. If G1 is in [isdnchan] or some other such context, you’d have to use an include statement:

include => isdnchan

to make certain that whatever functions you’re doing in that context can have access to the resources.


#7

Yes typo lol worked on this late lat night and got fat fingered.

Yes cell has access to G1 it completes the call 18661111111
I hear their system answer and goes into a menu press 1 for english 2 for spanish then it drops to press 1 if you have an account press 2 to establish
new service and so on but no matter what i push it does not reconize that I have pushed anything.
I changed 18661111111 to my cell number I can answer on my cell and here dtmf tones from pressing numbers on other phone.
It just bugs me why it doesnt work with there system because it works with others I set 18661111111 to another companys number (Direct TV)and it workes fine with there system


#8

Sheesh! You’re making this HARD!

Ok… Try this…

exten => 2,1,Dial(Zap/G1/18661111111,D(ww1w2))
exten => 3,1,Dial(Zap/G1/18661111111,D(ww1w2))

That dial command will dial the toll free number, wait 1 second, send the touch tone digit 1, wait half of a second and send the touch tone digit 2.

Modify the digits sent and the wait times to suit what you’d like to see pressed. See if you don’t end up in the correct place in the cell company IVR menu.

I’m interested in knowing if the IVR hears digits when they are generated by the Dial() command, or if they are even sent at all. The Asterisk won’t send them if it doesn’t get an ANSWER message back from the distant end.


#9

Sheesh! You’re making this HARD!
LOL told ya it ws a good one

Executing Dial(“Zap/55-1”, “Zap/G1/18661111111|D(ww1w2)”) in new stack
– Called G1/18661111111
Sep 8 13:59:25 WARNING[3422]: app_dial.c:869 dial_exec: Invalid timeout specified: ‘D(ww1w2)’


#10

I’m an idiot…

exten => 2,1,Dial(Zap/G1/18661111111,30,D(ww1w2))
exten => 3,1,Dial(Zap/G1/18661111111,30,D(ww1w2))

The 30 means that the system will wait for 30 seconds to hear that ANSWER isdn message it should be waiting for.

If it gets it, it should play the digits.


#11

Call went threw but still nothing never seen or heard D(ww1w2)) I sent you a PM it has a 800 number to dial and tells you how to get this to execute see if when you press digits it works… If you dont mind


#12

Thanks to the help from dufus we have determined the system works as long as you are calling from outside the office into the system. is just when I call from internal phone bak into the system the call fails to work with the cell companys menu. If i figure this out I will post more