FATAL: Module wcfxs not found, tdm04b (4 port fxo) SOLUTION

I recently compiled a gentoo machine with Asterisk…

Kernel 2.6.17-gentoo-r8

I have tried all the digium cards, and have had them all working, however when i put in the digium tdm04b card in (4 port fxo module bundle), i could not get the card working…

modprobe wctdm (gave me this)
FATAL: Module wcfxs not found

I noticed that the wcfxs module has been replaced with the wctdm module. I looked at the source of zaptel and found no module matching wcfxs, and in my kernel directory /lib/modules/2.6.17-gentoo-r8/misc/, there was no module either, here is an ls…

asterisk misc # ls
cwain.ko torisa.ko wct4xxp.ko wcusb.ko ztd-eth.ko
pciradio.ko wcfxo.ko wctdm.ko xpp ztd-loc.ko
qozap.ko wct1xxp.ko wctdm24xxp.ko zaphfc.ko ztdummy.ko
tor2.ko wct4xxp wcte11xp.ko zaptel.ko ztdynamic.ko

asterisk # modprobe -l | grep wctdm

asterisk # modprobe -l | grep wcfxs
asterisk #

As you can see, no result…

I eventually found that there were aliases in:


I just hashed out the line…

alias wctdm wcfxs

and everything worked after that…

Clearly the alias is wrong, and zaptel just inserts it incorrectly…

Have fun peepz :mrgreen: