ERROR[3017]: chan_zap.c:9106 start_pri: D-channel 24 is not


#1

Hi All,

We are putting a new asterisk server in as a backup and using a TE110p. I have chked evey thing and dont understand where the problem is because we are using the same config for our primary server which has a T100p so please can anyone help me out. my conf files and the output that i am getting is below.

thanks

[chan_zap.so] => (Zapata Telephony w/PRI)
== Parsing ‘/etc/asterisk/zapata.conf’: Found
– Registered channel 1, PRI Signalling signalling
– Registered channel 2, PRI Signalling signalling
– Registered channel 3, PRI Signalling signalling
– Registered channel 4, PRI Signalling signalling
– Registered channel 5, PRI Signalling signalling
– Registered channel 6, PRI Signalling signalling
– Registered channel 7, PRI Signalling signalling
– Registered channel 8, PRI Signalling signalling
– Registered channel 9, PRI Signalling signalling
– Registered channel 10, PRI Signalling signalling
– Automatically generated pseudo channel
May 3 06:41:35 ERROR[3017]: chan_zap.c:9106 start_pri: D-channel 24 is not in HDLC/FCS mode. See /etc/zaptel.conf
May 3 06:41:35 ERROR[3017]: chan_zap.c:10906 setup_zap: Unable to start D-channel on span 1
May 3 06:41:35 WARNING[3017]: loader.c:414 __load_resource: chan_zap.so: load_module failed, returning -1
– Unregistered channel 1
– Unregistered channel 2
– Unregistered channel 3
– Unregistered channel 4
– Unregistered channel 5
– Unregistered channel 6
– Unregistered channel 7
– Unregistered channel 8
– Unregistered channel 9
– Unregistered channel 10
– Unregistered channel 11
May 3 06:41:35 WARNING[3017]: loader.c:554 load_modules: Loading module chan_zap.so failed!

/etc/zaptel.conf
loadzone=au
defaultzone=au
span=1,1,0,ccs,hdb3,crc4
bchan=1-15,17-24
dchan=16

/etc/asterisk/zapata.conf
[channels]
switchtype = euroisdn
context = from-pstn
signalling = pri_cpe
echocancel = yes
echocancelwhenbridged = yes
echotraining = yes
txgain = -4.00
rxgain = -1.0
group = 1
usecallingpres = yes
amaflags = default
musiconhold = default
faxdetect = incoming
channel => 1-10


#2

Since channel 24 is used as D-channel (which is wrong: should be 16 for Österreich), i would MASSIVLY suspect your cardjumper is set to T1…
(Jumper to E1)