E1 Channel configuration - "Internally Clocked" pr


#1

Hello,

I am trying to configure a TE110P card to work with an E1 line (see my config settings below). After I do modprobe zaptel and modprobe wcte11xp first, ztcfg runs without any problems.

However, when I run zttool, it shows a RED Alarm on the card’s span. It also shows the card’s sync source as “Internally clocked”, when the settings for the span in zaptel.config should have set it to synchronise with the E1 it is interfacing with (re: http://www.marko.net/asterisk/archives/0211/0512.html)

In zaptel.config I have:

span=1,1,0,ccs,hdb3
bchan=1-15
dchan=16
bchan=17-31
loadzone=uk
defaultzone=uk

and in zapata.conf (among other settings):

signalling=pri_cpe
rxgain=0.0
txgain=0.0
group=1
channel=1-15,17-31

Any ideas why I can’t get the sync right, please?
Thank you,
Victoria.


#2

The configuration looks correct. Make sure you are using a T1/E1 cable and most probably it will need to be a cross over cable. Also check and make sure the card is taking interrupts ( cat /proc/interrupts ). See if the numbers increase each time you do the command. zttool reports the timing wrong, so whatever is set in your zaptel.conf is what it will use for timing.


#3

Thank you for your reply, angler,

The cable is E1 cross over. I have tried the cat /proc/interrupts, and and the count for my XT-PIC t1xxp grows ok. The zttool now shows no alarms for the card span at all, but the sync source still reads “internally clocked”.

We’ve now narrowed the problem down to layer2, and on one of the forums I’ve noticed a reference to the fact that zaptel use “inverted signalling bits”? Could that be the problem? Do you know anything about that at all, please?

Thank you,

Victoria


#4

did you ever get this internal sync problem sorted out.

I have this same problem at one of my client sites, but my card does not allow use of a cross over cable.

Please please help.