Disable Incoming DTMF recognition

Hello everyone,

My dialplan follows this behaviour: every outbound call plays a 10 second recording in the destination side. To achieve this, I use the command Dial with the flag A. For example:
same => n,Dial(SIP/FXS/${EXTEN},40,L(1800000:60000:30000)rA(/var/lib/asterisk/sounds/random)

This works perfectly, except for one thing: if the callee press any button while the recording is being played, it stops, and both sides can talk. This only happens if the callee press the button, if the caller does the same, nothing happens. Due to several reasons, I need the record to be played until the end, so I need to find a way to ignore the DTMF input, at least, while the recording is played. Any ideas?

Best regards

Use the Macro or Gosub option in the dial command, play the announcement and then continue the call.


Thank you, I have to perform further tests before using it in my production system, but until now it works great! It makes exactly what I need.

Best regards