Digium Cards UEFI non-compatibility

Can anyone recommend a PC or server that can be purchased that works with Digium cards. I am currently having the problem below with a TE134 not working in a new Dell T40 server. Digium support says it could be compatibility or a bad card so I am looking for a machine I can buy that I can test the card in.

I am getting zero interrupts for a new Digium TE134 Card on a new brand new Dell T40 server with the latest BIOS. Is there something that I am missing or is the card not compatible with Dell servers?

(cat /proc/interrupts ; sleep 1 ; cat /proc/interrupts) | grep -i wcte13xp0
16: 0 0 0 0 IR-IO-APIC 16-fasteoi i801_smbus, wcte13xp0
16: 0 0 0 0 IR-IO-APIC 16-fasteoi i801_smbus, wcte13xp0

lsmod | grep wcte13xp
wcte13xp 61440 24
oct612x 184320 1 wcte13xp
dahdi 241664 74 oct612x,wcte13xp

lspci -vv

03:00.0 Network controller: Digium, Inc. Wildcard TE134 single-span T1/E1/J1 card (rev 02)
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- SERR- <PERR- INTx+
Latency: 32 (1000ns min, 3750ns max)
Interrupt: pin A routed to IRQ 16
Region 0: Memory at b1000000 (32-bit, non-prefetchable) [size=128K]
Kernel driver in use: wcte13xp
Kernel modules: wcte13xp

dmidecode 3.2

Getting SMBIOS data from sysfs.
SMBIOS 3.1.1 present.
Table at 0x000E0000.

Handle 0x0000, DMI type 0, 26 bytes
BIOS Information
Vendor: Dell Inc.
Version: 1.3.1
Release Date: 07/03/2020
Address: 0xF0000
Runtime Size: 64 kB
ROM Size: 32 MB

/usr/sbin/dahdi_cfg -vvv
DAHDI Tools Version - 3.1.0

DAHDI Version: 3.1.0
Echo Canceller(s): HWEC
Configuration

SPAN 1: ESF/B8ZS Build-out: 0 db (CSU)/0-133 feet (DSX-1)

Channel map:

Channel 01: FXS Kewlstart (Default) (Echo Canceler: none) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Echo Canceler: none) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Echo Canceler: none) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Echo Canceler: none) (Slaves: 04)
Channel 05: FXS Kewlstart (Default) (Echo Canceler: none) (Slaves: 05)
Channel 06: FXS Kewlstart (Default) (Echo Canceler: none) (Slaves: 06)
Channel 07: FXS Kewlstart (Default) (Echo Canceler: none) (Slaves: 07)
Channel 08: FXS Kewlstart (Default) (Echo Canceler: none) (Slaves: 08)
Channel 09: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 09)
Channel 10: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 10)
Channel 11: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 11)
Channel 12: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 12)
Channel 13: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 13)
Channel 14: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 14)
Channel 15: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 15)
Channel 16: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 16)
Channel 17: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 17)
Channel 18: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 18)
Channel 19: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 19)
Channel 20: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 20)
Channel 21: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 21)
Channel 22: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 22)
Channel 23: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 23)
Channel 24: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 24)

24 channels to configure.

DAHDI_SPANCONFIG failed on span 1: Input/output error (5)

I like the cut of your budget!

Maybe try a Dell from 2015 that’s still getting firmware updates and see how it goes ?

Got a T1 loop back cable in there ? Any lights on the card ?