DEHADI & Asterisk installation

Hi guys,
I am new in Asterisk and i want to install it on my VPS.
I followed this tutorial:

I faced an error problem during build DEHDI before installing Asterisk:

[root@vps-1113750-12708 ~]# cd dahdi-linux-complete*
[root@vps-1113750-12708 dahdi-linux-complete-2.5.0+2.5.0]# make all
make -C linux all
make[1]: Entering directory /root/dahdi-linux-complete-2.5.0+2.5.0/linux' make -C drivers/dahdi/firmware firmware-loaders make[2]: Entering directory/root/dahdi-linux-complete-2.5.0+2.5.0/linux/drivers/dahdi/firmware’
make[2]: Leaving directory /root/dahdi-linux-complete-2.5.0+2.5.0/linux/drivers/dahdi/firmware' You do not appear to have the sources for the 2.6.32-042stab057.1 kernel installed. make[1]: *** [modules] Error 1 make[1]: Leaving directory/root/dahdi-linux-complete-2.5.0+2.5.0/linux’
make: *** [all] Error 2
[root@vps-1113750-12708 dahdi-linux-complete-2.5.0+2.5.0]#

If anybody have any idea please help.

Install the kernel-devel package for the kernel into which you are booting, or boot into a kernel for which you have kernel-devel package. This is frequently asked!

Thanks David55,
I already installed kernel-devel package using
yum install kernel-devel -y
But I still have the problem and it says to me that you already have the latest version of kernel.
Would you please help in how to boot in kernel?


Please Google. This is a common problem and there will be many replies explaining the solution.

Please also read carefully that I said matches the booted version, not the latest version.

E.g. try Googling: asterisk “You do not appear to have the sources for”

i was with same problem, but my version is diferent dahdi-linux, and the same error:
You do not appear to have the sources for the…el6.x86_64 kernel installed.
others kernel and same error continuous…

yum groupinstall "Development Tools"
yum update

yum install bison bison-devel ncurses ncurses-devel zlib zlib-devel openssl openssl-devel gnutls-devel gcc gcc-devel gcc-c++ libxml2 libxml2-devel newt newt-devel sqlite sqlite-devel glibc glibc-devel readline readline-devel libtermcap libtermcap-devel make make-devel libtool libtool-devel libtermcap libtermcap-devel unixodbc unixodbc-devel perl perl-Net-SSLeay perl-Crypt-SSLeay doxygen curl-devel mlocate lynx tar wget nmap bzip2 mod_ssl crontabs vixie-cron speex speex-devel unixODBC unixODBC-devel libtool-ltdl libtool-ltdl-devel ImageMagick ImageMagick-devel ImageMagick-perl

both installed and updated and reboot, but error continuous…
the same messenger show too in others kernel versions and all are update last version,

but after hours trying a solution, i fixed it error msg, using this dahdi (live):

svn checkout dahdi-linux
svn checkout dahdi-tools
cd dahdi-linux
so, i did make && make install, etc

font/source: … quirements

and all right!
i’m using centos 6.5 last kernel and kernel-devel and try too 6.4 and 6.3
now it is work pretty well in all.

sorry my bad english, any thing call me :wink: