DAHDI installation on Oracle Linux

Hi everyone. I checked related topics and was not able to resolve my issue. I am new here and just start learning how Asterisk works. I was following an Asterisk book and almost everything was installed but then I encountered an issue while installing DAHDI on Oracle Linux 8 (Kernel-devel was installed). I tried 3 different DAHDI versions dahdi-linux-complete-3.3.0+3.3.0, dahdi-linux-complete-2.8.0+2.8.0, dahdi-linux-complete-2.10.0+2.10.0.
This is what I see while trying to run make inside dahdi-linux-complete-3.3.0+3.3.0:

And, of course, because of that there is no way to install LIBPRI

You need to install the kernel development package for the running version of the Linux Kernel. On some distributions, that is kernel-devel

kernel-devel was installed many times and still same error

Maybe try rebooting and reinstalling? This should synchronize your running kernel with the most recently installed headers. Even minor kernel updates can break compiling of drivers.

Hello did you run these cmds?
yum install kernel*

dnf install -y kernel kernel-core kernel-modules
kernel-devel-$(uname -r) kernel-headers-$(uname -r)

ln -s /usr/src/kernels/$(uname -r) build

cd dahdi-linux-complete-3.3.0+3.3.0/
ln -sf /usr/lib/modules/$(uname -r)/vmlinux.xz /boot/
make install
make install-config

cd tools
cp system.conf.sample /etc/dahdi/system.conf

make clean
make && make install
make install-config

dahdi_genconf -v
dahdi_cfg -vvvvvvvvv

Hello, when I use this command

dnf install -y kernel kernel-core kernel-modules
kernel-devel-$(uname -r) kernel-headers-$(uname -r)
it shows

after running ‘make’

the rest of commands

yum install -y dahdi-tools-libs
yum install dwarves

Next, check if the vmlinux file is located in /sys/kernel/btf by running:

ls /sys/kernel/btf
If the vmlinux file is present, copy it to the appropriate directory using the following command:

cp /sys/kernel/btf/vmlinux /usr/lib/modules/$(uname -r)/build/
In this command, $(uname -r) is used to get the current kernel version, and /usr/lib/modules/$(uname -r)/build/ is the directory where the vmlinux file is expected to be found.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.