DAHDI and ksplice


#1

I’m trying to install dahdi but having some issues.

When doing make it says I do not have the 2.6.18-274.7.1.el5 source. I tried to install but says the newest 2.6.18-274.12.1.el5 is already installed. I found out the server is running ksplice(not too familiar with this) but server is actually running at 2.6.18-274.12.1.el5 when entering this command: uptrack-uname -r.

I tried to make/install with: KVERS=2.6.18-274.12.1.el5. Everything looks fine but I do get one warning:
WARNING: could not find /usr/src/dahdi-linux-complete-2.5.0.2+2.5.0.2/linux/drivers/dahdi/vpmadt032_loader/.vpmadt032_x86_64.o.cmd for /usr/src/dahdi-linux-complete-2.5.0.2+2.5.0.2/linux/drivers/dahdi/vpmadt032_loader/vpmadt032_x86_64.o

Then when trying to start dahdi this is what I get:

[code]-bash-3.2# service dahdi start
Loading DAHDI hardware modules:
FATAL: Module dahdi not found.
wct4xxp: FATAL: Module wct4xxp not found.
[FAILED]
wcte12xp: FATAL: Module wcte12xp not found.
[FAILED]
wct1xxp: FATAL: Module wct1xxp not found.
[FAILED]
wcte11xp: FATAL: Module wcte11xp not found.
[FAILED]
wctdm24xxp: FATAL: Module wctdm24xxp not found.
[FAILED]
wcfxo: FATAL: Module wcfxo not found.
[FAILED]
wctdm: FATAL: Module wctdm not found.
[FAILED]
wcb4xxp: FATAL: Module wcb4xxp not found.
[FAILED]
wctc4xxp: FATAL: Module wctc4xxp not found.
[FAILED]
xpp_usb: FATAL: Module xpp_usb not found.
[FAILED]

Error: missing /dev/dahdi![/code]

Any ideas? Here is the output from running make: pastebin.com/yYzXvmQW


#2

It looks like you have installed 2.6.18-274-12.1.el5 but are running 2.6.18-274.7.1.el5.

If you can’t reboot your system try running in the dahdi-linux directory:

$ make clean
$ yum install kernel-devel-$(uname -r)
$ make install

Then you shouldn’t get the warning about not having the 2.6.18-274-7.1.el5 source installed.


#3

Thank you scruffel. That did solve the problem I was having originally and everything was running great.

I actually have a new problem related to the kernel now. Yesterday they decided to install some vm stuff on the server and it changed the kernel to 2.6.18-274.7.1.el5.028stab095.1

Now it says the kernel source is not there again and can’t download that from yum. I tried doing a soft link to the 2.6.18-274.7.1.el5 in /lib/module. Everything builds fine but getting errors like:

Loading DAHDI hardware modules: FATAL: Error inserting dahdi (/lib/modules/2.6.18-274.12.1.el5/dahdi/dahdi.ko): Unknown symbol in module, or unknown parameter (see dmesg) wct4xxp: WARNING: Error inserting dahdi (/lib/modules/2.6.18-274.12.1.el5/dahdi/dahdi.ko): Unknown symbol in module, or unknown parameter (see dmesg) FATAL: Error inserting wct4xxp (/lib/modules/2.6.18-274.12.1.el5/dahdi/wct4xxp/wct4xxp.ko): Unknown symbol in module, or unknown parameter (see dmesg) [FAILED]

I then just tried doing the KVERS again but that still doesnt work. Any ideas about the new issue?


#4

That looks like one of the openvz kernels, so you’ll need to find that development package. My guess is the following command will work for you:

You might also want to ask whoever keeps changing the kernel on that box to make sure they always install the kernel-devel package for you.