Dahdi 2.4.0 not installing on centos 5.5

2 issues that i encountered during the installation of the process. one was dahdi complaining about a mismatch between the kernel sources directory name and the kernel name reported by uname -r which i fixed (?) with a soft link. the other one is a warning popping up about missing vpmadt032_loader:

WARNING: could not find /opt/dahdi-linux-complete-2.4.0+2.4.0/linux/drivers/dahdi/vpmadt032_loader/.vpmadt032_x86_32.o.cmd for /opt/dahdi-linux-complete-2.4.0+2.4.0/linux/drivers/dahdi/vpmadt032_loader/vpmadt032_x86_32.o
the end result is that a /dev/dahdi directory is not created, and asterisk meetme conferences would fail. happens on 3 centos 5.5 machines that i tried, none of them having any digium hardware inside. i tried dahdi 2.1.1 (if i remember right) and failed in a very similar way.

any thoughts? thank you.

Did you use the default installation paths or custom paths?


/dev/dahdi isn’t going to be present until you load some kind of dahdi module, e.g. dahdi_dummy.

you’re right. i was thinking at /dev/dahdi being there after starting the dahdi service. but the dahdi service does this:

[root@mymachine somewhere]# service dahdi start Loading DAHDI hardware modules: FATAL: Module dahdi not found. wct4xxp: FATAL: Module wct4xxp not found. [FAILED] wcte12xp: FATAL: Module wcte12xp not found. [FAILED] wct1xxp: FATAL: Module wct1xxp not found. [FAILED] wcte11xp: FATAL: Module wcte11xp not found. [FAILED] wctdm24xxp: FATAL: Module wctdm24xxp not found. [FAILED] wcfxo: FATAL: Module wcfxo not found. [FAILED] wctdm: FATAL: Module wctdm not found. [FAILED] wcb4xxp: FATAL: Module wcb4xxp not found. [FAILED] wctc4xxp: FATAL: Module wctc4xxp not found. [FAILED] xpp_usb: FATAL: Module xpp_usb not found. [FAILED]

So the soft-link might not have worked.

What was the fail message on the installation attempt before you made that link?

uname -r 2.6.18-194.el5
error was:

You do not appear to have the sources for the 2.6.18-194.el5 kernel installed.
after yum install kernel-devel i had /usr/src/kernels/2.6.18-194.26.1.el5-i686 and i created a soft link like 2.6.18-194.el5-i686 -> 2.6.18-194.26.1.el5-i686. that took it beyond the “you do not appear to have the sources” issue, but im not sure it was a good idea…

From this article:
jonathanmanning.com/2010/12/ … -tutorial/

Try the KSRC= includes before make and make install.

Sorry, I don’t have a CentOS machine to test on presently.

tried it, then looking at the Makefile’s i figured out it’s about the same thing, either using a KSRC variable or a softlink. :frowning:

malcom, i appreciate your help, man, let me know if you would be available to log into my machine. thanks!


Sorry, I can’t do that. :frowning:

We do support for OSS Asterisk here:


[quote=“drivefast”]uname -r 2.6.18-194.el5
error was:

You do not appear to have the sources for the 2.6.18-194.el5 kernel installed.

Please try the following method:

uname -r


wget ftp://ftp.muug.mb.ca/mirror/centos/5.5/ … 5.i686.rpm

rpm -ivh kernel-devel-2.6.18-194.el5.i686.rpm

yum list installed kernel-devel

if you can see the line like this: kernel-devel.i686 2.6.18-194.el5 installed
congratulations ! otherwise, please try other method.

thank you, it’s great to get congratulations for the small steps that i make every hour now :smile: i did install kernel-devel from the default repo (and frankly i’m not adventurous enough to install it from the place you suggest). so yeah, it was on before i created the thread. some other things that are on: gtk+, gtk2-devel, ncurses, ncurses-devel, kernel-PAE, kernel-PAE-devel.

yeah, that’s what i thought, i wasnt sure if you would or would not be able to. but your support has appreciated nonetheless.

No problem.

Sunking’s suggestion is a fine one; I wouldn’t be worried about grabbing a kernel package from that location.