Creating extensions begining with *


#1

Note: Firstly my asterisk, has no zaptel card or hardphone.

I want to create a *70 extension to check voice mail, however my softphone I get an invalid URI when it is dialed. Is there something else that I need to do to have this extension work?


#2

Need more info on your environment. Is your softphone connected to the Asterisk? What is its default context? And how is that context configured in the /etc/asterisk/extensions.conf file?

Or are you using Asterisk@Home?


#3

[asterisk]-----[switch]-----[computer]------[softphone]

The context is called ‘intern’ and the extension is ‘2202’. I can dial other softphone on the network, but dialing an extension that starts with * does not go through.


#4

Still not enough information. We need to see the section from your extensions.conf and the output from your logs or the output from a verbose CLI.


#5

Sorry about that Muppetmaster, I managed to resolve the problem with some help from Scott Laird. Using the command: sip debug peer I noticed that when the *70 calls where made it looked for it as *70@local . My local context did not have *70 extension… it was located within the inter-post context. So I made an include that linked them and it worked.

Thanks though.