Configuring a polycom 500

if anyone has already configured a polycom 500 can you please expain how to do it. I do not understand it one bit. I tried resetting with 456 at setup but then i don’t know what to do afterward. I tried anyway and received something about boot error. Then read different online documentation about different firmware that needs to be downloaded. i am just confused now. my dhcp (router) does not even appear to see it and i cannot find any web interface at all.

The response from the display is “cannot contact boot server using existing configuration” and i cannot get to the web interface that the display lists as its ip address. I have no idea what a tftp is or what should go in the sntp so i left ithem blank, as well as the domain name.

Just confused.

I’m only using Polycom phones with my clients so I’ve got this down to a science.

First off, set up your dhcp (if you have one, if not I suggest using one) to hand out option 66 and put in the ip address for the ftp server you’re using to hand out the Polycom config files.

On your ftp server, create a user with a username AND password of PlcmSpIp. Put all of your config files in there.

Put as much of the config as you can in the sip.cfg file. The only stuff I have in the individual phone configs relates to their line info and the messages button stuff. I can post examples if you need.

Hold down 468* and reset the flash in the phone. It should boot up and pull option 66 which will tell it to log into the ftp server using the above username and password. It will grab the bootrom.ld and, if newer, update itself. Same with the sip.ld. Then the phone will load it’s config.

If you boot the phone up and set the config options either on the phone itself or in the web interface those settings will be written back to the macaddress-phone.cfg file on the ftp server.

If you need more help let me know!


I will start setting up again, I see the ip address on the phone after pressing the about button, that the dhcp allocated but i have no idea where these config files are that you are talking about. Do i put them onto a server of my own, and then ftp them to myself or…are they at some particular site where i ftp them to myself? A little confused about the config files, part. I have been reading some lierature about a bootROM which i downloaded to my windows OS machine, again a little confused about what to do with it. It was not indicated in the user guide, but i looked on line in an admin guide, which is where i found this bootROM data and found an asterisk site where to get it if needed. Do I need it and what version should I be downloading, there several version to choose from.

If you can elaborate on where these config files are and how and where to ftp them would be great…


Oh, and yes, could you post your examples that you mentioned. Any and all help appreciated.


Okay, i am makling some progress now. I activated my tftp, and vsftpd and created username/password and am selecting to go with the ftp method to continue with the configuration of IP 500, and I have located all of the latest config files.

Okay, I’m attaching a link to my sip.cfg and a macaddress-phone.cfg file. I use these config files for every Asterisk system I set up and just change the relavent addresses. Let me know if you need more help.


Hello again,
And thanks for sharing your data. Stumped again. I setup the ftp okay and can reach ftp server from command prompt with username/password as PlcmSpIp but when i try to get it from the phone, i am still not able to connect to ftp server, however, i do not believe i am actually getting pass the phone setup portion. I now receive this error: “Failled to get boot parameters via DHCP”. In the FTP server area, I input my * server ip address which also has the bootrom.ld, .cfg, .and .xml files. However, the phone is setup behind a machine running on a nat’d firewall, with ip addresses dynamically allocated by the router. So, I only put the default gateway of the router’s address in the designated area on the phone’s setup display screen and left the DNS server, alt server both blank. Is this how your polycom is configured? Or do i also need to input this machines server ip address and alternate ip address (dynamic host machine)? If so, when i do this, it still fails to find boot server with a DHCP error (and the about button displays the ip address of my static ip rather than the router’d ip). Again, i input my static address pointing to another machine in the FTP Server area of the display screen.

Need assistance to determine where my phone misconfiguration lies…

Okay, explain your network to me again. Where is your Asterisk server in relation to your phone? Are they on the same network?

Okay, i got it with the welcome download of bootrom, etc. Finally! Thanks much.

But, how longs does it display on the screen “Welcome! Processing configuraiton…this may take a few seconds?” This has been displayed a good 10-20 minutes or so already. (And no the machines are not on the same network, one is on a router while another is on it’s own static ip but they talk)

Explain to me where the Asterisk server is in relation to the phone. The phone is behind a router and the Asterisk server is somewhere else? Explain the whole thing to me. The phone gets it’s config via ftp (that’s the best way to do it - tftp sucks when used with these phones). In your phone you put in the ip address of the ftp server and make sure the phone is set to use ftp. On the Asterisk server you have ftp services set up and you can log in using PlcmSpIp for the username and password. Once you log in via ftp do you see all of the config files? Do you have the configuration file named using the correct mac address of the phone? Make sure all the letters in the name are lowercase.


yes, my mac address matches and files were uploaded to my root directory as well mac_address.boot.log, etc, indidcating ftp works (and again I had already tested ftp using the command line to acccess ftp via password/username). What i would like to know is what revision do you have for your polycom 500, i downloaded rev 1.6.6 from one of asterisk voip sites?

yes, my mac address matches and files were uploaded to my root directory as well mac_address.boot.log, etc, indidcating ftp works (and again I had already tested ftp using the command line to acccess ftp via password/username). What i would like to know is what revision do you have for your polycom 500, i downloaded rev 1.6.6 from one of asterisk voip sites?[/quote]

It’s working. What happened is: About an hour ago when i initially started the bootrom download, my internet connection was lost everywhere. So i flashed bootrom and started again and now date and time and other icons display on the screen as it should. And I can now access the web interface for the Polycom 500. Thanks for your support.

Hi all,

I thought I had this all figured out. Should this be this difficult? Anyway, now i cannot get polycom to register. What is it exactly that i need to input in the web interface as i cannot find any current documentation for the web interface. When I look on the display of the phone, it clearly says Line1 not registered and I do not see any indicationof it registered with * either. Also, i read somewhere that I should have a ipmid.cfg file (Main configuration file, also least likely to need modification beyond initial setup), but i do not. Is this normal too?

Thanks in advance…

I use this tring for opt 66 on DHCP server:

no need to continue with this post. The polycom is now all registered and working now.