ConfBridge - Record

I have question with ConfBridge

I tried use :

before ConfBridge command, but the asterisk dont record file with this name

.  exten=>_x.,1,Answer()

This should work, make sure you have the correct permissions to write on the recording path

I think to has same problems in this function, because my directory have 777 permission , I tried put in /var/spool/asterisk/monitor/test.wav and dont work too.

What does the CLI shows ?
and did you add the closing parenthesis )

The parenthesis its ok:

Executing [123@sala-senha:8] Set(“PJSIP/9301-00000001”, “CONFBRIDGE(bridge,record_file)=/var/spool/asterisk/monitor/test.wav”) in new stack
– Executing [123@sala-senha:9] ConfBridge(“PJSIP/9301-00000001”, “1234,default_bridge,default_user1234”) in new stack
– Channel CBAnn/1234-00000001;2 joined ‘softmix’ base-bridge <0babbf83-90a0-486b-b571-c6a264798c63>
== Begin MixMonitor Recording CBRec/1234-00000001
– Channel CBRec/1234-00000001 joined ‘softmix’ base-bridge <0babbf83-90a0-486b-b571-c6a264798c63>
– <PJSIP/9301-00000001> Playing ‘conf-onlyperson.slin’ (language ‘pt_BR’)
> 0x7fde00014470 – Strict RTP learning complete - Locking on source address
– <PJSIP/9301-00000001> Playing ‘confbridge-join.gsm’ (language ‘pt_BR’)
– <CBAnn/1234-00000001;1> Playing ‘confbridge-join.gsm’ (language ‘en’)
– Channel PJSIP/9301-00000001 joined ‘softmix’ base-bridge <0babbf83-90a0-486b-b571-c6a264798c63>
– Channel PJSIP/9301-00000001 left ‘softmix’ base-bridge <0babbf83-90a0-486b-b571-c6a264798c63>
– Channel CBRec/1234-00000001 left ‘softmix’ base-bridge <0babbf83-90a0-486b-b571-c6a264798c63>
== MixMonitor close filestream (mixed)
== End MixMonitor Recording CBRec/1234-00000001
– <CBAnn/1234-00000001;1> Playing ‘confbridge-leave.gsm’ (language ‘en’)
– Channel CBAnn/1234-00000001;2 left ‘softmix’ base-bridge <0babbf83-90a0-486b-b571-c6a264798c63>

I discovery,
When you call app ConfBridge you need put only name of room, if you put name of room , bridge profile and user_profile the custom recorder doesn’t work

I just gave you an example, but you were calling confbridge like this

If You call Confbridge with this method ConfBridge(234,default_bridge,default_user1234), the recorder call dont work, because the asterisk load configs from default_bridge

Only work if you call

it is a logical approach, parameters passed to the confbridge app will override your previous settings