CID on FXS port


#1

Hi,

With help from this forum and cyber-cottage.co.uk I’ve configured the FXO port on my tdm400 to work fine with UK CID. It’s pretty reliable with the console showing incoming PSTN numbers around 7 times out of every 10 attempts.

My problem is getting CID to work on my two FXS ports, into which are connected two Philips cordless base stations. I did have them working at one point; at the time I had configured zaptel.conf for US settings. I’ve tried tweaking the config options for the cordless phones without success; I’ve listed below my zaptel.conf & zapata.conf files:

zaptel.conf

fxoks=2
fxoks=3
fxsks=4
loadzone=uk
defaultzone=uk

zapata.conf

[channels]
context=from-internal
signalling=fxo_ks
echocancel=yes
immediate=no
channel=2-3

context=from-pstn
signalling=fxs_ks
busydetect=yes
callprogress=no
busycount=>4
relaxdtmf=>yes
hanguponpolarityswitch=yes
callwaiting=>yes
callwaitingcallerid=>
threewaycalling=>no
transfer=>yes
cancallforward=>yes
usedistinctiveringdetection=>
;UK Caller ID
callerid=asreceived
usecallerid=yes
cidsignalling=v23
cidstart=usehist
;UK BT Callsign ring patterns
dring1=366,246,216
dring2=246,98,0
dring1context=ringring_ringring
dring2context=ring_ring
echotraining = yes
echocancel = yes
echocancelwhenbridged = yes
musiconhold = default
immediate=yes
rxgain=1 ;set to reduce echo
txgain=4 ;set to reduce echo
faxdetect=incoming
channel=4

I did try setting cidsignalling=v23 & cidstart=usehist in the FXS section at the top without any joy. Any comments would be welcomed.

Regards,
Chris


#2

On the FSO the following lines in zapata.conf with do the tric for UK (with a TDM400P card)

usecallerid=yes
cidsignalling=v23 ; Added for UK CLI detection
cidstart=polarity ; Added for UK CLI detection
restrictcid=no
hidecallerid=no

For the FSX I have tried many option with no success.
The Asterisk console gices the following error

WARNING[16651]: chan_zap.c:3950 zt_handle_event: Didn’t finish Caller-ID spill. Cancelling.

I use Asterisk 1.2.5 and zaptel-1.2.4

Any idea ?