Newbie CID question


#1

I received my TDM400 card yesterday and have so far had fairly good luck, the installation went smooth on my Fedora Core 4 system.

So far I’ve been trying out a variety of scenarios, the one thing I’ve had no luck with is getting caller ID to work. I have one FXO module in port 4 of the TDM400 and two FXS modules in ports 2 & 3. I have connected a Philips Onis 200 Dect Base station into port 2 and port 4 into my BT phone socket.

The Philips phone has various CID configuration options to allow for different operator scenarios (I had to alter this in my last house to get it working with Telewest) and I’ve tried each of these options in turn. In each case when I initiate a call from my mobile phone to the pstn number, I see errors like that below in the Asterisk console:

Oct 18 19:55:58 NOTICE[10496]: chan_zap.c:5816 ss_thread: Got event 2 (Ring/Answered)…
Oct 18 19:56:00 WARNING[10496]: chan_zap.c:5856 ss_thread: CID timed out waiting for ring. Exiting simple switch

or…

Oct 18 19:55:22 WARNING[10484]: chan_zap.c:3897 zt_handle_event: Didn’t finish Caller-ID spill. Cancelling.

The error varies depending on what operator type I set on the Dect phone.

I notice in each case, the following is displayed at the start of each incoming call:

== Starting post polarity CID detection on channel 4

I’ve cut the configuration right down to the bare minimum to avoid confusion; I’ve listed below my zaptel.conf, zapata.conf & extensions.conf files:

zaptel.conf
fxoks=2-3
fxsks=4
loadzone=uk
defaultzone=uk

zapata.conf
[channels]
callerid=asreceived
usecallerid=yes
cidsignalling=v23
cidstart=polarity
immediate=no
hanguponpolarityswitch=yes

context=internal
signalling=fxo_ks
echocancel=yes
channel=2-3

context=incoming-pstn
signalling=fxs_ks
echocancel=yes
channel=4

extensions.conf
[general]
static=yes
writeprotect=yes

[incoming-pstn]
exten => s,1,Dial(Zap/2)

If anyone’s seen similar issues and knows a solution, I’d greatly appreciate your feedback!

Cheers,
Chris


#2

For further info, I modified my extensions.conf and added the following lines:

[internal]
exten => 2222,1,Dial(Zap/2)
exten => 3333,1,Dial(Zap/3)

I then tried initiating a call from a phone connected to port 2 on the TDM400 and saw the error:

Oct 18 20:30:52 WARNING[11676]: chan_zap.c:3897 zt_handle_event: Didn’t finish Caller-ID spill. Cancelling.

I’m inferring that this means my CID problem is probably not the FXO, butrather the FXS (or at least it’s interaction with my phone).

Cheers,
Chris


#3

Generally your config looks good, though I would assign the callerid=asreceived to only your FXO port, as you will probably be setting a station caller ID (some sort of extension) for internal calls.

I poked around a bit, and found that some people seem to think that an rxwink setting may be in order for polarity shift style CID delivery.

Try setting rxwink=300 on your FXO port.

Click these for more help.

voip-info.org/wiki-Asterisk+and+UK+Caller+ID

voip-info.org/wiki-Asterisk+ … apata.conf

codepoets.co.uk/linux_asteri … ax_and_sip

wheely-bin.co.uk/asterisk/25/

Cheers!


#4

Even wiered, I changed zaptel.conf from:

fxoks=2-3
fxsks=4
loadzone=uk
defaultzone=uk

to…

fxoks=2-3
fxsks=4
loadzone=us
defaultzone=us

And managed to caller ID to display (I had to try a couple of ‘operator type’ options on the dect phone)!

Now I’m really confused. I guess it’s potentially a solution, I’ll just get a US dial tone between internal extensions :open_mouth:

Chris


#5

Thanks dufus,

I’ll give the rxwink option a try.

Cheers,
Chris