Checking asterisk voicemail from sip phone

Hi, I’m wondering if there is an quick way to check your asterisk voicemail from an extension on the network versus going to webmail. (i.e. dial pound from any phone plus mailbox number).



Take a look at VoicemailMain

Thank you.

I can’t get my Polycom IP500 to acknowlege star and pound keys, to I created an extension you can dial from anywhere.

; Dial 2500 from any phone to go to the voicemail system
exten => 2500,1,Wait,2
exten => 2500,2,VoicemailMain
exten => 2500,3,Hangup

I also fixed my dialplan as such so if I dial my own extension, it goes directly to my voicemail without having to enter the extension number:

; Standard extension macro
; ${ARG1} - Device extension(s) to ring
; ${ARG2} - Voicemail box
exten => s,hint,${ARG1}
exten => s,1,GotoIf($["${CALLERIDNUM}" = “${ARG2}”]?2:5)
;exten => s,2,Wait(1)
exten => s,2,NoOp
exten => s,3,VoiceMailMain(${ARG2})
exten => s,4,Hangup

exten => s,5,Dial(${ARG1},20) ; Ring the interface, 20 seconds maximum
exten => s,6,Goto(s-${DIALSTATUS},1) ; Jump based on status (NOANSWER,BUSY,CHANUNAVAIL,CONGESTION,ANSWER)

exten => s-BUSY,1,Voicemail(b${ARG2}) ; If busy, send to voicemail w/ busy announce
exten => s-BUSY,2,Hangup
;exten => s-BUSY,2,Goto(public,s,1) ; If they press #, return to start

exten => s-NOANSWER,1,Voicemail(u${ARG2}) ; If unavailable, send to voicemail w/ unavail announce
exten => s-NOANSWER,2,Hangup
;exten => s-NOANSWER,2,Goto(public,s,1) ; If they press #, return to start

exten => _s-.,1,Goto(s-NOANSWER,1) ; Treat anything else as no answer

I was able to access the comedian voicemail by dialing *98 and entered a mailbox number and password but for whatever reason it keeps saying password incorrect. I can log into comedian web with the extenion and password and it works perfectly (i.e. ext 100 password 100).

Ok, this is interesting. I can access my voicemail with xlite with no problems, however, I’m using a grandstream 286 for my analog phone and when I try to access the system through the grandstream it doesn’t work. Anyone know what modifications I need to make to the grandstream settings?


[quote=“gsmackay”]I can’t get my Polycom IP500 to acknowlege star and pound keys, to I created an extension you can dial from anywhere.

Why don’t you just use the callback feature in the Polycom phone configs so that the Voicemail (Messages in SIP 501 version) button works?

If you’re getting the main voicemail menu from the gs286, then it’s not the ATA config that is wrong, it’s Asterisk’s configs.

If you set the CIDnum for the phone(s) in sip.conf (etc) and you use this for getting to voicemail:

exten => 12345,1,VoicemailMain(s${CALLERIDNUM}@default)

calling 12345 will take you straight into the voicemail main menu without having to bother about PIN numbers etc. (Of course, you can change 12345 to anything you like.)