chan_zap compiles in 1.2, not in 1.4

I first tried compiling 1.4, which worked fine except that was not built. Repeated make clean and recompile, same result.

So I cleaned out 1.4 and built 1.2.14 on the same machine and appeared correctly.

Perhaps there is something in the Makefile that might explain why I can’t compile 1.4 fully? If there is a component missing surely make would stop on error? Anyone else seen this behaviour?

Clean out /usr/lib/asterisk/modules. Then you compile zaptel 1.4 cleanly. Then, in asterisk 1.4, do a ‘make menuconfig’, in there it will tell you of a dependency of chan_zap.

Thanks for the suggestion. I had tried make menuselect, but there are only 11 items in the list, ends at chan_oss. No chan_zap.

i know this is a daft question, but have you compiled (and maybe installed) zaptel 1.4 as well ?

No question is daft when dealing with odd puzzles!

Confirmed, modules directory wiped clean, make clean, reconfig linux26, make, make install on zaptel, in asterisk make clean, make menuselect/menuconfig, same result, no chan_zap. chan_zap.c definitely in source.

Looks like I shall have to remove all traces of asterisk and start from scratch.

have you looked at the configure script itself to see if there’s a command-line option for specifying where to find the zaptel files ?

or does configure generate a log that might give you a clue as to why it’s not available ?

Good suggestion baconbuttie - I pedantically specified in asterisk compile

make clean
./configure --with-zaptel=/usr/src/asterisk/zaptel-1.4.0
make menuselect

now I see 16 options in menuselect, and the last one is chan_zap which has a * so there are no dependencies lacking, at least for chan_zap.

But adding that one parameter to config allowed not only chan_zap to appear in menuconfig but several others as well. I have not sorted out which ones are new, but it is possible that it was choking on a different dependency.

update: is now compiled, as expected.